# CVE-2026-110870: Nodemailer before 10.0.13 Improper Input Validation via Angle-Bracket Address Comments

> Attackers can bypass domain allow-lists or cause delivery failures in Nodemailer by injecting RFC 5322 comments into email addresses.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Oct 2026
- **Updated:** 26 Oct 2026
- **Also known as:** CLSA-2026-1793180903, CLSA-2026-1793183905, CLSA-2026-1793187944, CLSA-2026-1793207112, CLSA-2026-1793209433, CLSA-2026-1793215120, CLSA-2026-1793267771, DEBIAN-CVE-2026-110870, ECHO-0cfa-c395-b902, GHSA-597p-2mmq-hhg9, GHSA-g73g-hqqh-jr95, UBUNTU-CVE-2026-110870

## What is CVE-2026-110870?

CVE-2026-110870 is a medium-severity vulnerability in nodemailer, published on 14 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Nodemailer from 3.0.0 before 10.0.13 contains an improper input validation vulnerability in its address parser that fails to strip RFC 5322 comments inside angle-bracket addresses. Attackers can supply recipients like a display name with a parenthesized comment in the domain, so illegal characters reach envelope.to and RCPT TO, causing rejected delivery or parser interpretation conflicts that bypass domain allow-lists.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-110870?

2 open source packages ship an affected version, including nodemailer.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nodemailer` | npm | From 3.0.0 | 10.0.13 |
| `nodemailer` | npm | From 3.0.0 | 10.0.13 |

## How do I fix CVE-2026-110870?

Upgrade nodemailer to 10.0.13 or later.

## Is CVE-2026-110870 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-110870 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-110870 and fix it if it is affected.

What it is: CVE-2026-110870 is a medium-severity vulnerability in nodemailer, published on 14 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-110870 exists.

Affected packages and fixed versions:
- nodemailer (npm): affected from 3.0.0; fixed in 10.0.13
- nodemailer (npm): affected from 3.0.0; fixed in 10.0.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-110870/ (Markdown: https://insights.sbomify.com/CVE-2026-110870/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-110870
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-110870
- OSV: https://osv.dev/vulnerability/CVE-2026-110870

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-110870/
Summaries are generated and may contain mistakes; the official description above is the record.
