{"answers":{"affected":"2 open source packages ship an affected version, including nodemailer.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-110872 exists.","fix":"Upgrade nodemailer to 10.0.10 or later.","what":"CVE-2026-110872 is a high-severity denial of service vulnerability in nodemailer, published on 14 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-110872 and fix it if it is affected.\n\nWhat it is: CVE-2026-110872 is a high-severity denial of service vulnerability in nodemailer, published on 14 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-110872 exists.\n\nAffected packages and fixed versions:\n- nodemailer (npm): affected from 3.0.0; fixed in 10.0.10\n- nodemailer (npm): affected from 3.0.0; fixed in 10.0.10\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-110872/ (Markdown: https://insights.sbomify.com/CVE-2026-110872/index.md)","id":"CVE-2026-110872","markdown":"https://insights.sbomify.com/CVE-2026-110872/index.md","name":"CVE-2026-110872","record":{"aliases":["CLSA-2026-1793102593","CLSA-2026-1793181005","CLSA-2026-1793183896","DEBIAN-CVE-2026-110872","ECHO-5c4c-bea4-f8fb","GHSA-37fc-hcrp-mmff","GHSA-4g23-2xm8-66gc","UBUNTU-CVE-2026-110872"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js email library","requires_auth":"none","summary":"A malicious SMTP server can cause a denial of service in Nodemailer by streaming continuation lines, blocking the event loop and exhausting memory.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":8.2,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"Nodemailer from 3.0.0 before 10.0.10 contains a quadratic complexity denial of service vulnerability in the SMTP client reply parser in SMTPConnection._onData and isPartialResponse. A malicious SMTP server or on-path attacker can stream continuation lines without a completion line before authentication, blocking the Node.js event loop and exhausting memory.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Nodemailer 3.0.0 before 10.0.10 Denial of Service via SMTP Reply Parsing","id":"CVE-2026-110872","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"Heym 0.0.55 before 0.0.121 Credential Theft via error_workflow_id Field","id":"CVE-2026-110873"},"packages":[{"ecosystem":"npm","fixed":["10.0.10"],"introduced":["3.0.0"],"last_affected":[],"package":"nodemailer","purl":null,"source":"GHSA-4g23-2xm8-66gc"},{"ecosystem":"npm","fixed":["10.0.10"],"introduced":["3.0.0"],"last_affected":[],"package":"nodemailer","purl":"pkg:npm/nodemailer","source":"GHSA-4g23-2xm8-66gc"}],"prev":{"headline":"Nodemailer 3.0.0 before 10.0.10 Quadratic DKIM Header Unfolding Denial of Service","id":"CVE-2026-110871"},"products":["nodemailer"],"published":"2026-10-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-15","vendors":["nodemailer"]},"summary":"A malicious SMTP server can cause a denial of service in Nodemailer by streaming continuation lines, blocking the event loop and exhausting memory.","url":"https://insights.sbomify.com/CVE-2026-110872/"}