# CVE-2026-110909: Missing authorization in Wheels CLI

> A malicious local process can intercept sensitive project data and modify state by impersonating the development server during CLI operations.

- **Severity:** Medium 5.0 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 15 Oct 2026
- **Updated:** 20 Oct 2026
- **Also known as:** GHSA-8qgh-9996-h3c4, GHSA-x3cm-2j3q-jgg4

## What is CVE-2026-110909?

CVE-2026-110909 is a medium-severity missing authorization vulnerability in Wheels CLI, published on 15 Oct 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Wheels CLI through 4.1.0 does not verify that the local development server answering its HTTP requests belongs to the current project. A process listening on a port targeted by the CLI can receive the project's reload password and code submitted through wheels reload or wheels console; console also probes common ports when the project server is down. Other commands can perform unintended state-changing operations against a different local application's server and database. Exploitation requires a process listening on a targeted local port and the developer running an affected command. This is fixed in 4.1.1, including changes to the CLI and application template.

Weakness: CWE-923 (Improper Restriction of Communication Channel to Intended Endpoints)

## Which versions are affected by CVE-2026-110909?


## How do I fix CVE-2026-110909?

No fix has been published for CVE-2026-110909 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-110909 being exploited?

There is no known exploitation of CVE-2026-110909 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-110909 and fix it if it is affected.

What it is: CVE-2026-110909 is a medium-severity missing authorization vulnerability in Wheels CLI, published on 15 Oct 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-110909 in the wild and no public exploit code.

Affected product: Wheels CLI. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-110909/ (Markdown: https://insights.sbomify.com/CVE-2026-110909/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-110909
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-110909
- OSV: https://osv.dev/vulnerability/CVE-2026-110909

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-110909/
Summaries are generated and may contain mistakes; the official description above is the record.
