# CVE-2026-111057: Mercury: Unauthenticated Remote Code Execution in /api/terminals - access control bypass

> An unauthenticated attacker can bypass access controls to execute arbitrary commands and read data via the terminal API in Mercury.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Oct 2026
- **Updated:** 28 Oct 2026
- **Also known as:** GHSA-f8c7-rwf9-fmgm

## What is CVE-2026-111057?

CVE-2026-111057 is a critical authentication bypass vulnerability in mljar mercury, published on 19 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Mercury is a Python framework for sharing Jupyter notebooks as web applications and dashboards. From 3.0.0 until 3.2.4, a missing comma in BLOCKED_PATTERNS concatenates the /lab and /api/terminals regular-expression literals. Requests to /api/terminals therefore bypass the anonymous endpoint blocklist and reach Jupyter Server's terminal API. An unauthenticated attacker can use the resulting interactive operating-system shell to execute commands and access data available to the Mercury process. This issue is fixed in version 3.2.4.

Weakness: CWE-284 (Improper Access Control), CWE-185 (Incorrect Regular Expression)

## Which versions are affected by CVE-2026-111057?

2 open source packages ship an affected version, including mercury.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mercury` | PyPI | From 3.0.0 | 3.2.4 |
| `mercury` | PyPI | From 3.0.0 | 3.2.4 |

## How do I fix CVE-2026-111057?

Upgrade mercury to 3.2.4 or later.

## Is CVE-2026-111057 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-111057 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-111057 and fix it if it is affected.

What it is: CVE-2026-111057 is a critical authentication bypass vulnerability in mljar mercury, published on 19 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-111057 exists.

Affected packages and fixed versions:
- mercury (PyPI): affected from 3.0.0; fixed in 3.2.4
- mercury (PyPI): affected from 3.0.0; fixed in 3.2.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-111057/ (Markdown: https://insights.sbomify.com/CVE-2026-111057/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-111057
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-111057
- OSV: https://osv.dev/vulnerability/CVE-2026-111057

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-111057/
Summaries are generated and may contain mistakes; the official description above is the record.
