# CVE-2026-111059: Mercury: Stored / DOM Cross-Site Scripting (XSS): mr.Markdown renders untrusted content as raw, unsanitized HTML

> Attackers can inject malicious scripts via Markdown content in Mercury applications, leading to code execution in victim browsers.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Oct 2026
- **Updated:** 20 Oct 2026
- **Also known as:** GHSA-2658-85cv-9wwq

## What is CVE-2026-111059?

CVE-2026-111059 is a medium-severity cross-site scripting vulnerability in mljar mercury, published on 19 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Mercury is a Python framework for sharing Jupyter notebooks as web applications and dashboards. From 3.0.0 until 3.2.11, mr.Markdown converts attacker-controlled Markdown to HTML without sanitizing raw HTML before assigning it to an ipywidgets.HTML sink. Event-handler attributes and other active HTML can therefore reach the DOM and execute when another user views the application. This issue is fixed in version 3.2.11.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2026-111059?

2 open source packages ship an affected version, including mercury.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mercury` | PyPI | From 3.0.0 | 3.2.11 |
| `mercury` | PyPI | From 3.0.0 | 3.2.11 |

## How do I fix CVE-2026-111059?

Upgrade mercury to 3.2.11 or later.

## Is CVE-2026-111059 being exploited?

There is no known exploitation of CVE-2026-111059 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-111059 and fix it if it is affected.

What it is: CVE-2026-111059 is a medium-severity cross-site scripting vulnerability in mljar mercury, published on 19 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-111059 in the wild and no public exploit code.

Affected packages and fixed versions:
- mercury (PyPI): affected from 3.0.0; fixed in 3.2.11
- mercury (PyPI): affected from 3.0.0; fixed in 3.2.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-111059/ (Markdown: https://insights.sbomify.com/CVE-2026-111059/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-111059
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-111059
- OSV: https://osv.dev/vulnerability/CVE-2026-111059

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-111059/
Summaries are generated and may contain mistakes; the official description above is the record.
