# CVE-2026-1114: Improper Access Control via Weak JWT Token in parisneo/lollms

> Attackers can brute-force weak JWT secrets to forge admin tokens, enabling privilege escalation and unauthorized access in lollms.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Apr 2026
- **Updated:** 7 Apr 2026
- **Also known as:** GHSA-9296-v3fr-j92j, PYSEC-2026-170

## What is CVE-2026-1114?

CVE-2026-1114 is a critical vulnerability in parisneo/lollms, published on 7 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In parisneo/lollms version 2.1.0, the application's session management is vulnerable to improper access control due to the use of a weak secret key for signing JSON Web Tokens (JWT). This vulnerability allows an attacker to perform an offline brute-force attack to recover the secret key. Once the secret key is obtained, the attacker can forge administrative tokens by modifying the JWT payload and resigning it with the cracked secret. This enables unauthorized users to escalate privileges, impersonate the administrator, and gain access to restricted endpoints. The issue is resolved in version 2.2.0.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-1114?

3 open source packages ship an affected version, including lollms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lollms` | PyPI | All versions to 2.1.0 | None |
| `lollms` | PyPI | All versions | 2.2.0 |
| `lollms` | PyPI | All versions | 2.2.0 |

Products: Lollms Lollms.

## How do I fix CVE-2026-1114?

Upgrade lollms to 2.2.0 or later.

## Is CVE-2026-1114 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-1114 exists.

## Other vulnerabilities in parisneo/lollms

- [CVE-2024-3429](https://insights.sbomify.com/CVE-2024-3429/): Path Traversal in parisneo/lollms (critical 9.8)
- [CVE-2026-1115](https://insights.sbomify.com/CVE-2026-1115/): Stored XSS in parisneo/lollms (critical 9.6)
- [CVE-2026-12228](https://insights.sbomify.com/CVE-2026-12228/): Stored XSS in Direct Messages via Prompt Sharing in parisneo/lollms (high 8.7)
- [CVE-2026-0562](https://insights.sbomify.com/CVE-2026-0562/): Insecure Direct Object Reference (IDOR) in parisneo/lollms (high 8.3)
- [CVE-2026-1116](https://insights.sbomify.com/CVE-2026-1116/): Cross-site Scripting (XSS) in parisneo/lollms (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-1114 and fix it if it is affected.

What it is: CVE-2026-1114 is a critical vulnerability in parisneo/lollms, published on 7 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-1114 exists.

Affected packages and fixed versions:
- lollms (PyPI): affected all versions up to 2.1.0; no fix listed
- lollms (PyPI): affected all versions; fixed in 2.2.0
- lollms (PyPI): affected all versions; fixed in 2.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-1114/ (Markdown: https://insights.sbomify.com/CVE-2026-1114/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-1114
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-1114
- OSV: https://osv.dev/vulnerability/CVE-2026-1114

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-1114/
Summaries are generated and may contain mistakes; the official description above is the record.
