# CVE-2026-111447: Wheels 1.1 through 4.1.2 resolves nestedProperties() records by posted primary key without checking that they belong to the parent being saved.


- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 16 Oct 2026
- **Updated:** 21 Oct 2026
- **Also known as:** GHSA-3qfm-8v6g-jr47, GHSA-6979-65wv-7pxq

## What is CVE-2026-111447?

CVE-2026-111447 is a high-severity vulnerability in Wheels, published on 16 Oct 2026. 

### Official description

Wheels 1.1 through 4.1.2 resolves nestedProperties() records by posted primary key without checking that they belong to the parent being saved. A user able to submit a nested form for their own parent can update and reassign another parent's hasMany or hasOne rows, or delete them when allowDelete=true. Nested belongsTo records can also be edited by posting another associated record's key. New child rows with composite primary keys not made up of foreign keys retain posted key values, allowing the request to choose their identity. This is fixed in 4.2.0.

Weakness: CWE-472 (External Control of Assumed-Immutable Web Parameter)

## Which versions are affected by CVE-2026-111447?


## How do I fix CVE-2026-111447?

No fix has been published for CVE-2026-111447 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-111447 being exploited?

There is no known exploitation of CVE-2026-111447 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-111447 and fix it if it is affected.

What it is: CVE-2026-111447 is a high-severity vulnerability in Wheels, published on 16 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-111447 in the wild and no public exploit code.

Affected product: Wheels. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-111447/ (Markdown: https://insights.sbomify.com/CVE-2026-111447/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-111447
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-111447
- OSV: https://osv.dev/vulnerability/CVE-2026-111447

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-111447/
Summaries are generated and may contain mistakes; the official description above is the record.
