# CVE-2026-1115: Stored XSS in parisneo/lollms

> Attackers can inject malicious JavaScript into social posts, leading to account takeover and session hijacking for users viewing the feed.

- **Severity:** Critical 9.6 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Apr 2026
- **Updated:** 10 Apr 2026
- **Also known as:** GHSA-8wrq-fv5f-pfp2, PYSEC-2026-401

## What is CVE-2026-1115?

CVE-2026-1115 is a critical cross-site scripting vulnerability in parisneo/lollms, published on 10 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A Stored Cross-Site Scripting (XSS) vulnerability was identified in the social feature of parisneo/lollms, affecting the latest version prior to 2.2.0. The vulnerability exists in the `create_post` function within `backend/routers/social/__init__.py`, where user-provided content is directly assigned to the `DBPost` model without sanitization. This allows attackers to inject and store malicious JavaScript, which is executed in the browsers of users viewing the Home Feed, including administrators. This can lead to account takeover, session hijacking, and wormable attacks. The issue is resolved in version 2.2.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-1115?

3 open source packages ship an affected version, including lollms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lollms` | PyPI | All versions | 2.2.0 |
| `lollms` | PyPI | All versions | 2.2.0 |
| `lollms` | PyPI | All versions | 2.2.0 |

Products: Lollms Lollms.

## How do I fix CVE-2026-1115?

Upgrade lollms to 2.2.0 or later.

## Is CVE-2026-1115 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-1115 exists.

Public exploit code:

- parisneo/lollms < 2.2.0 - Authenticated Stored XSS (nuclei): http/cves/2026/CVE-2026-1115.yaml

## Other vulnerabilities in parisneo/lollms

- [CVE-2026-1114](https://insights.sbomify.com/CVE-2026-1114/): Improper Access Control via Weak JWT Token in parisneo/lollms (critical 9.8)
- [CVE-2024-3429](https://insights.sbomify.com/CVE-2024-3429/): Path Traversal in parisneo/lollms (critical 9.8)
- [CVE-2026-12228](https://insights.sbomify.com/CVE-2026-12228/): Stored XSS in Direct Messages via Prompt Sharing in parisneo/lollms (high 8.7)
- [CVE-2026-0562](https://insights.sbomify.com/CVE-2026-0562/): Insecure Direct Object Reference (IDOR) in parisneo/lollms (high 8.3)
- [CVE-2026-1116](https://insights.sbomify.com/CVE-2026-1116/): Cross-site Scripting (XSS) in parisneo/lollms (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-1115 and fix it if it is affected.

What it is: CVE-2026-1115 is a critical cross-site scripting vulnerability in parisneo/lollms, published on 10 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-1115 exists.

Affected packages and fixed versions:
- lollms (PyPI): affected all versions; fixed in 2.2.0
- lollms (PyPI): affected all versions; fixed in 2.2.0
- lollms (PyPI): affected all versions; fixed in 2.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-1115/ (Markdown: https://insights.sbomify.com/CVE-2026-1115/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-1115
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-1115
- OSV: https://osv.dev/vulnerability/CVE-2026-1115

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-1115/
Summaries are generated and may contain mistakes; the official description above is the record.
