# CVE-2026-1116: Cross-site Scripting (XSS) in parisneo/lollms

> Attackers can inject malicious scripts via unsanitized content fields, leading to account takeover or session hijacking in lollms applications.

- **Severity:** High 8.2 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Apr 2026
- **Updated:** 13 Apr 2026
- **Also known as:** GHSA-w676-j9x4-3hq2, PYSEC-2026-2200

## What is CVE-2026-1116?

CVE-2026-1116 is a high-severity cross-site scripting vulnerability in parisneo/lollms, published on 12 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A Cross-site Scripting (XSS) vulnerability was identified in the `from_dict` method of the `AppLollmsMessage` class in parisneo/lollms prior to version 2.2.0. The vulnerability arises from the lack of sanitization or HTML encoding of the `content` field when deserializing user-provided data. This allows an attacker to inject malicious HTML or JavaScript payloads, which can be executed in the context of another user's browser. Exploitation of this vulnerability can lead to account takeover, session hijacking, or wormable attacks.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-1116?

1 open source package ship an affected version, including lollms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lollms` | PyPI | All versions | 2.1.1 |

Products: Lollms Lollms.

## How do I fix CVE-2026-1116?

Upgrade lollms to 2.1.1 or later.

## Is CVE-2026-1116 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-1116 exists.

## Other vulnerabilities in parisneo/lollms

- [CVE-2026-1114](https://insights.sbomify.com/CVE-2026-1114/): Improper Access Control via Weak JWT Token in parisneo/lollms (critical 9.8)
- [CVE-2024-3429](https://insights.sbomify.com/CVE-2024-3429/): Path Traversal in parisneo/lollms (critical 9.8)
- [CVE-2026-1115](https://insights.sbomify.com/CVE-2026-1115/): Stored XSS in parisneo/lollms (critical 9.6)
- [CVE-2026-12228](https://insights.sbomify.com/CVE-2026-12228/): Stored XSS in Direct Messages via Prompt Sharing in parisneo/lollms (high 8.7)
- [CVE-2026-0562](https://insights.sbomify.com/CVE-2026-0562/): Insecure Direct Object Reference (IDOR) in parisneo/lollms (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-1116 and fix it if it is affected.

What it is: CVE-2026-1116 is a high-severity cross-site scripting vulnerability in parisneo/lollms, published on 12 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-1116 exists.

Affected packages and fixed versions:
- lollms (PyPI): affected all versions; fixed in 2.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-1116/ (Markdown: https://insights.sbomify.com/CVE-2026-1116/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-1116
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-1116
- OSV: https://osv.dev/vulnerability/CVE-2026-1116

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-1116/
Summaries are generated and may contain mistakes; the official description above is the record.
