{"answers":{"affected":"3 open source packages ship an affected version, including lollms.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-1117 exists.","fix":"Upgrade lollms to 2.1.0 or later.","what":"CVE-2026-1117 is a high-severity missing authorization vulnerability in parisneo/lollms, published on 2 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-1117 and fix it if it is affected.\n\nWhat it is: CVE-2026-1117 is a high-severity missing authorization vulnerability in parisneo/lollms, published on 2 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-1117 exists.\n\nAffected packages and fixed versions:\n- lollms (PyPI): affected all versions; fixed in 2.1.0\n- lollms (PyPI): affected all versions; fixed in 2.1.0\n- lollms (PyPI): affected all versions; fixed in 2.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-1117/ (Markdown: https://insights.sbomify.com/CVE-2026-1117/index.md)","id":"CVE-2026-1117","markdown":"https://insights.sbomify.com/CVE-2026-1117/index.md","name":"CVE-2026-1117","record":{"aliases":["GHSA-82fw-ch24-j34w","PYSEC-2026-1586"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["denial_of_service","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"lollms AI platform","requires_auth":"none","summary":"Unauthenticated attackers can trigger sensitive Socket.IO events in lollms, causing denial of service and state corruption due to missing access controls.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntr_ai","cpe":[],"cvss":{"score":8.2,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H","version":"3.0"},"cwes":[{"id":"CWE-284","name":"Improper Access Control"}],"description":"A vulnerability in the `lollms_generation_events.py` component of parisneo/lollms version 5.9.0 allows unauthenticated access to sensitive Socket.IO events. The `add_events` function registers event handlers such as `generate_text`, `cancel_generation`, `generate_msg`, and `generate_msg_from` without implementing authentication or authorization checks. This allows unauthenticated clients to execute resource-intensive or state-altering operations, leading to potential denial of service, state corruption, and race conditions. Additionally, the use of global flags (`lollmsElfServer.busy`, `lollmsElfServer.cancel_gen`) for state management in a multi-client environment introduces further vulnerabilities, enabling one client's actions to affect the server's state and other clients' operations. The lack of proper access control and reliance on insecure global state management significantly impacts the availability and integrity of the service.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Improper Access Control in parisneo/lollms","id":"CVE-2026-1117","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"missing_authorization","year":"2026"},"n_packages":3,"n_references":2,"next":{"headline":"itsourcecode Society Management System add_activity.php sql injection","id":"CVE-2026-1118"},"packages":[{"ecosystem":"PyPI","fixed":["2.1.0"],"introduced":["0"],"last_affected":[],"package":"lollms","purl":null,"source":"GHSA-82fw-ch24-j34w"},{"ecosystem":"PyPI","fixed":["2.1.0"],"introduced":["0"],"last_affected":[],"package":"lollms","purl":"pkg:pypi/lollms","source":"GHSA-82fw-ch24-j34w"},{"ecosystem":"PyPI","fixed":["2.1.0"],"introduced":["0"],"last_affected":[],"package":"lollms","purl":"pkg:pypi/lollms","source":"PYSEC-2026-1586"}],"prev":{"headline":"Cross-site Scripting (XSS) in parisneo/lollms","id":"CVE-2026-1116"},"products":["parisneo/lollms"],"published":"2026-02-02","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-02-02","vendors":["parisneo"]},"summary":"Unauthenticated attackers can trigger sensitive Socket.IO events in lollms, causing denial of service and state corruption due to missing access controls.","url":"https://insights.sbomify.com/CVE-2026-1117/"}