# CVE-2026-1117: Improper Access Control in parisneo/lollms

> Unauthenticated attackers can trigger sensitive Socket.IO events in lollms, causing denial of service and state corruption due to missing access controls.

- **Severity:** High 8.2 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Feb 2026
- **Updated:** 2 Feb 2026
- **Also known as:** GHSA-82fw-ch24-j34w, PYSEC-2026-1586

## What is CVE-2026-1117?

CVE-2026-1117 is a high-severity missing authorization vulnerability in parisneo/lollms, published on 2 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability in the `lollms_generation_events.py` component of parisneo/lollms version 5.9.0 allows unauthenticated access to sensitive Socket.IO events. The `add_events` function registers event handlers such as `generate_text`, `cancel_generation`, `generate_msg`, and `generate_msg_from` without implementing authentication or authorization checks. This allows unauthenticated clients to execute resource-intensive or state-altering operations, leading to potential denial of service, state corruption, and race conditions. Additionally, the use of global flags (`lollmsElfServer.busy`, `lollmsElfServer.cancel_gen`) for state management in a multi-client environment introduces further vulnerabilities, enabling one client's actions to affect the server's state and other clients' operations. The lack of proper access control and reliance on insecure global state management significantly impacts the availability and integrity of the service.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-1117?

3 open source packages ship an affected version, including lollms.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lollms` | PyPI | All versions | 2.1.0 |
| `lollms` | PyPI | All versions | 2.1.0 |
| `lollms` | PyPI | All versions | 2.1.0 |

## How do I fix CVE-2026-1117?

Upgrade lollms to 2.1.0 or later.

## Is CVE-2026-1117 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-1117 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-1117 and fix it if it is affected.

What it is: CVE-2026-1117 is a high-severity missing authorization vulnerability in parisneo/lollms, published on 2 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-1117 exists.

Affected packages and fixed versions:
- lollms (PyPI): affected all versions; fixed in 2.1.0
- lollms (PyPI): affected all versions; fixed in 2.1.0
- lollms (PyPI): affected all versions; fixed in 2.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-1117/ (Markdown: https://insights.sbomify.com/CVE-2026-1117/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-1117
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-1117
- OSV: https://osv.dev/vulnerability/CVE-2026-1117

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-1117/
Summaries are generated and may contain mistakes; the official description above is the record.
