# CVE-2026-111749: AIOHTTP: Cookie from subdomain can remove Host-Only Scope from existing cookies

> A malicious subdomain can strip host-only protections from existing cookies in the aiohttp library, potentially weakening cookie isolation mechanisms.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Oct 2026
- **Updated:** 22 Oct 2026
- **Also known as:** AZL-110692, DEBIAN-CVE-2026-111749, ECHO-a1d2-3cce-f75b, GHSA-gx76-c99x-2c96, MINI-36q4-q7m6-h4cx, MINI-88j2-483r-j3r5, MINI-m58f-6xpj-j45c, UBUNTU-CVE-2026-111749

## What is CVE-2026-111749?

CVE-2026-111749 is a low-severity vulnerability in aio-libs aiohttp, published on 19 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

AIOHTTP is an asynchronous HTTP client/server framework for asyncio and Python. Prior to 3.14.4, Host-Only scope on an existing parent-domain cookie can be removed by a subdomain. A user who accesses an untrusted subdomain can consequently have host-only protections stripped from cookies, although impact is limited when applications do not reflect those cookies to a browser. This issue is fixed in version 3.14.4.

Weakness: CWE-565 (Reliance on Cookies without Validation and Integrity Checking)

## Which versions are affected by CVE-2026-111749?

2 open source packages ship an affected version, including aiohttp.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `aiohttp` | PyPI | All versions | 3.14.4 |
| `aiohttp` | PyPI | All versions | 3.14.4 |

## How do I fix CVE-2026-111749?

Upgrade aiohttp to 3.14.4 or later.

## Is CVE-2026-111749 being exploited?

There is no known exploitation of CVE-2026-111749 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-111749 and fix it if it is affected.

What it is: CVE-2026-111749 is a low-severity vulnerability in aio-libs aiohttp, published on 19 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-111749 in the wild and no public exploit code.

Affected packages and fixed versions:
- aiohttp (PyPI): affected all versions; fixed in 3.14.4
- aiohttp (PyPI): affected all versions; fixed in 3.14.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-111749/ (Markdown: https://insights.sbomify.com/CVE-2026-111749/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-111749
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-111749
- OSV: https://osv.dev/vulnerability/CVE-2026-111749

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-111749/
Summaries are generated and may contain mistakes; the official description above is the record.
