CVE-2026-111758 markdown-it: Quadratic-time rendering of a single multi-line link reference definition with default options (regression since 14.0)
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2026-111758?
CVE-2026-111758 is a high-severity vulnerability in markdown-it, published on 20 Oct 2026.
Official description
markdown-it is a Markdown parser. From versions 14.1.0 to before 14.3.3, and 15.0.0 to before 15.0.3, a link reference definition whose label or title is never closed is O(n²) with default options. Continuation lines are pulled lazily with str += lineContent in src/rules_block/reference.ts, and the subsequent charCodeAt and slice calls flatten the V8 cons-string, copying everything collected so far; this runs before the rule decides the definition is invalid. No options are required to trigger it. This issue has been patched in versions 14.3.3 and 15.0.3.
Which versions are affected by CVE-2026-111758?
4 open source packages ship an affected version, including markdown-it.
| Package | Affected | Fixed in |
|---|---|---|
markdown-it npm | From 14.1.0 | 14.3.3 |
markdown-it npm | From 14.1.0 | 14.3.3 |
markdown-it npm | From 15.0.0 | 15.0.3 |
markdown-it npm | From 15.0.0 | 15.0.3 |
How do I fix CVE-2026-111758?
Upgrade markdown-it to a fixed version for your release line: 14.3.3 or 15.0.3.
Is CVE-2026-111758 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-111758 exists.
Sources
Also known as CLSA-2026-1792582446, CLSA-2026-1792595173, ECHO-b9d4-14d0-7241, GHSA-gfr2-rv44-r23c, ROOT-APP-NPM-CVE-2026-111758, UBUNTU-CVE-2026-111758.