# CVE-2026-111758: markdown-it: Quadratic-time rendering of a single multi-line link reference definition with default options (regression since 14.0)


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 20 Oct 2026
- **Updated:** 28 Oct 2026
- **Also known as:** CLSA-2026-1792582446, CLSA-2026-1792595173, ECHO-b9d4-14d0-7241, GHSA-gfr2-rv44-r23c, ROOT-APP-NPM-CVE-2026-111758, UBUNTU-CVE-2026-111758

## What is CVE-2026-111758?

CVE-2026-111758 is a high-severity vulnerability in markdown-it, published on 20 Oct 2026. 

### Official description

markdown-it is a Markdown parser. From versions 14.1.0 to before 14.3.3, and 15.0.0 to before 15.0.3, a link reference definition whose label or title is never closed is O(n²) with default options. Continuation lines are pulled lazily with str += lineContent in src/rules_block/reference.ts, and the subsequent charCodeAt and slice calls flatten the V8 cons-string, copying everything collected so far; this runs before the rule decides the definition is invalid. No options are required to trigger it. This issue has been patched in versions 14.3.3 and 15.0.3.

Weakness: CWE-407 (Inefficient Algorithmic Complexity), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-111758?

4 open source packages ship an affected version, including markdown-it.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `markdown-it` | npm | From 14.1.0 | 14.3.3 |
| `markdown-it` | npm | From 14.1.0 | 14.3.3 |
| `markdown-it` | npm | From 15.0.0 | 15.0.3 |
| `markdown-it` | npm | From 15.0.0 | 15.0.3 |

## How do I fix CVE-2026-111758?

Upgrade markdown-it to a fixed version for your release line: 14.3.3 or 15.0.3.

## Is CVE-2026-111758 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-111758 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-111758 and fix it if it is affected.

What it is: CVE-2026-111758 is a high-severity vulnerability in markdown-it, published on 20 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-111758 exists.

Affected packages and fixed versions:
- markdown-it (npm): affected from 14.1.0; fixed in 14.3.3
- markdown-it (npm): affected from 14.1.0; fixed in 14.3.3
- markdown-it (npm): affected from 15.0.0; fixed in 15.0.3
- markdown-it (npm): affected from 15.0.0; fixed in 15.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-111758/ (Markdown: https://insights.sbomify.com/CVE-2026-111758/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-111758
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-111758
- OSV: https://osv.dev/vulnerability/CVE-2026-111758

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-111758/
Summaries are generated and may contain mistakes; the official description above is the record.
