CVE-2026-111808 Apache Traffic Server: HTTP/2 DATA frame padding underflow lets a client trigger backend worker-pool exhaustion

High 7.7 Published Updated
Exploited in the wild
Not known
Fix
None listed

What is CVE-2026-111808?

CVE-2026-111808 is a high-severity vulnerability in Apache Traffic Server, published on 21 Oct 2026.

Official description

Apache Traffic Server can be used to exhaust an HTTP/1.1 origin's worker pool via a malformed padded HTTP/2 DATA frame.

This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.15, from 10.0.0 through 10.1.4, 10.2.0.

Users are recommended to upgrade to version 9.2.16, 10.1.5, or 10.2.1, which fix the issue.

Weakness: CWE-191

Which versions are affected by CVE-2026-111808?

How do I fix CVE-2026-111808?

No fix has been published for CVE-2026-111808 yet. Limit exposure of the affected software until one is available.

Is CVE-2026-111808 being exploited?

There is no known exploitation of CVE-2026-111808 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2026-111808, GHSA-93mv-pcxw-4fpr, UBUNTU-CVE-2026-111808.

Is CVE-2026-111808 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free