# CVE-2026-111917: Vikunja 2.3.0 before 2.7.0 WebSocket Authentication Ignores Session Revocation

> Attackers with stolen tokens maintain WebSocket access after session revocation, continuing to receive private task and project notifications.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 17 Oct 2026
- **Updated:** 19 Oct 2026
- **Also known as:** GHSA-355w-rx9g-pww7, GHSA-4hv6-xc92-j86g, GO-2026-6715

## What is CVE-2026-111917?

CVE-2026-111917 is a high-severity authentication bypass vulnerability in go-vikunja vikunja, published on 17 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Vikunja 2.3.0 before 2.7.0 contains an improper session validation vulnerability that allows attackers to keep WebSocket access after revocation because handleAuth never checks the JWT sid claim against the sessions table. Attackers holding a stolen access token can open or maintain connections to /api/v2/ws after session deletion or TOTP enrollment, continuing to receive the victim's notification.created pushes, including comment, task and project content.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2026-111917?

3 open source packages ship an affected version, including code.vikunja.io/api.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `code.vikunja.io/api` | Go | All versions | None |
| `code.vikunja.io/api` | Go | From 2.3.0 | 2.7.0 |
| `code.vikunja.io/api` | Go | From 2.3.0 | 2.7.0 |

## How do I fix CVE-2026-111917?

Upgrade code.vikunja.io/api to 2.7.0 or later.

## Is CVE-2026-111917 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-111917 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-111917 and fix it if it is affected.

What it is: CVE-2026-111917 is a high-severity authentication bypass vulnerability in go-vikunja vikunja, published on 17 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-111917 exists.

Affected packages and fixed versions:
- code.vikunja.io/api (Go): affected all versions; no fix listed
- code.vikunja.io/api (Go): affected from 2.3.0; fixed in 2.7.0
- code.vikunja.io/api (Go): affected from 2.3.0; fixed in 2.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-111917/ (Markdown: https://insights.sbomify.com/CVE-2026-111917/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-111917
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-111917
- OSV: https://osv.dev/vulnerability/CVE-2026-111917

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-111917/
Summaries are generated and may contain mistakes; the official description above is the record.
