# CVE-2026-111932: Coder before 2.34.2 Stored HTML Injection via Appearance Settings

> Attackers with Owner role can inject HTML into appearance settings, leading to XSS in dashboards and emails, potentially compromising user accounts.

- **Severity:** Medium 4.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:N/VI:L/VA:N/SC:N/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Oct 2026
- **Updated:** 22 Oct 2026
- **Also known as:** GHSA-7cmx-x3cj-5mp3, GHSA-h58c-xccx-75m3, GO-2026-6267

## What is CVE-2026-111932?

CVE-2026-111932 is a medium-severity cross-site scripting vulnerability in coder, published on 17 Oct 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Coder before 2.29.17, 2.30.0 before 2.32.7, 2.33.0 before 2.33.8, and 2.34.0 before 2.34.2 contains a stored HTML injection vulnerability because the ApplicationName and LogoURL appearance settings are rendered into HTML output without sufficient escaping. Attackers with the Owner role can store HTML markup in these settings that renders in the Coder dashboard and in SMTP notification emails sent to other deployment users.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-111932?

10 open source packages ship an affected version, including github.com/coder/coder/v2 and github.com/coder/coder.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/coder/coder/v2` | Go | All versions | 2.29.17, 2.32.7, 2.33.8, 2.34.2 |
| `github.com/coder/coder/v2` | Go | All versions | 2.29.17 |
| `github.com/coder/coder/v2` | Go | All versions | 2.29.17 |
| `github.com/coder/coder/v2` | Go | From 2.30.0 | 2.32.7 |
| `github.com/coder/coder/v2` | Go | From 2.30.0 | 2.32.7 |
| `github.com/coder/coder/v2` | Go | From 2.33.0 | 2.33.8 |
| `github.com/coder/coder/v2` | Go | From 2.33.0 | 2.33.8 |
| `github.com/coder/coder/v2` | Go | From 2.34.0 | 2.34.2 |
| `github.com/coder/coder/v2` | Go | From 2.34.0 | 2.34.2 |
| `github.com/coder/coder` | Go | All versions | None |

## How do I fix CVE-2026-111932?

Upgrade github.com/coder/coder/v2 to a fixed version for your release line: 2.29.17, 2.32.7, 2.33.8 or 2.34.2.

## Is CVE-2026-111932 being exploited?

There is no known exploitation of CVE-2026-111932 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-111932 and fix it if it is affected.

What it is: CVE-2026-111932 is a medium-severity cross-site scripting vulnerability in coder, published on 17 Oct 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-111932 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/coder/coder/v2 (Go): affected all versions; fixed in 2.29.17, 2.32.7, 2.33.8, 2.34.2
- github.com/coder/coder/v2 (Go): affected all versions; fixed in 2.29.17
- github.com/coder/coder/v2 (Go): affected all versions; fixed in 2.29.17
- github.com/coder/coder/v2 (Go): affected from 2.30.0; fixed in 2.32.7
- github.com/coder/coder/v2 (Go): affected from 2.30.0; fixed in 2.32.7
- github.com/coder/coder/v2 (Go): affected from 2.33.0; fixed in 2.33.8
- github.com/coder/coder/v2 (Go): affected from 2.33.0; fixed in 2.33.8
- github.com/coder/coder/v2 (Go): affected from 2.34.0; fixed in 2.34.2
- github.com/coder/coder/v2 (Go): affected from 2.34.0; fixed in 2.34.2
- github.com/coder/coder (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-111932/ (Markdown: https://insights.sbomify.com/CVE-2026-111932/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-111932
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-111932
- OSV: https://osv.dev/vulnerability/CVE-2026-111932

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-111932/
Summaries are generated and may contain mistakes; the official description above is the record.
