CVE-2026-112085 webpack-dev-server vulnerable to cross-origin WebSocket access via proxied upgrades

High 8.2 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2026-112085?

CVE-2026-112085 is a high-severity vulnerability in webpack-dev-server, published on 22 Oct 2026.

Official description

webpack-dev-server is a development server that provides live reloading for webpack projects. In versions before 5.2.7 and in version 6.0.0, when a proxy entry is configured to forward WebSockets, the server forwards non-HMR WebSocket upgrade requests to the proxy target without validating the Host or Origin headers, so the allowedHosts protection does not apply to those proxied upgrades. A malicious web page visited by a developer can open a cross-origin WebSocket through the dev server and read from and write to the proxied backend, even when the server is bound to loopback. The issue is fixed in webpack-dev-server 5.2.7 and 6.1.0, where proxied WebSocket upgrades pass the same Host and Origin validation as the HMR WebSocket, and users should upgrade to one of those versions or later. As a workaround, omit WebSocket forwarding from proxy entries that do not need it and scope the proxy to specific paths.

Weakness: CWE-346, CWE-1385

Which versions are affected by CVE-2026-112085?

It affects 1 product.

Products include Webpack.js Webpack-Dev-Server.

How do I fix CVE-2026-112085?

Upgrade to a fixed version.

Is CVE-2026-112085 being exploited?

There is no known exploitation of CVE-2026-112085 in the wild and no public exploit code.

Sources

Also known as AZL-111065, GHSA-cfqc-fj3v-j925, UBUNTU-CVE-2026-112085.

Is CVE-2026-112085 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free