# CVE-2026-112101: BlackBeltTechnology pi-agent-dashboard WebSocket Gateway origin validation


- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 19 Oct 2026
- **Updated:** 19 Oct 2026
- **Also known as:** GHSA-wx6r-347g-2f27

## What is CVE-2026-112101?

CVE-2026-112101 is a medium-severity vulnerability in BlackBeltTechnology pi-agent-dashboard, published on 19 Oct 2026. 

### Official description

A vulnerability was determined in BlackBeltTechnology pi-agent-dashboard up to 0.8.0. The affected element is an unknown function of the file /BlackBeltTechnology/pi-agent-dashboard of the component WebSocket Gateway. Executing a manipulation of the argument cwd can lead to origin validation error. The attack can be executed remotely. The exploit has been publicly disclosed and may be utilized. Upgrading to version 0.9.0 is sufficient to fix this issue. This patch is called 48fd0bad5adfe76af9736599699d51a5f60019f6. It is recommended to upgrade the affected component.

Weakness: CWE-346 (Origin Validation Error), CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2026-112101?


## How do I fix CVE-2026-112101?

No fix has been published for CVE-2026-112101 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-112101 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-112101 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-112101 and fix it if it is affected.

What it is: CVE-2026-112101 is a medium-severity vulnerability in BlackBeltTechnology pi-agent-dashboard, published on 19 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-112101 exists.

Affected product: BlackBeltTechnology pi-agent-dashboard. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-112101/ (Markdown: https://insights.sbomify.com/CVE-2026-112101/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-112101
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-112101
- OSV: https://osv.dev/vulnerability/CVE-2026-112101

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-112101/
Summaries are generated and may contain mistakes; the official description above is the record.
