CVE-2026-112105 GlitterWare Passy TLS main.dart MyHttpOverrides certificate validation

Medium 6.3 Published Updated
Exploited in the wild
Not known
Fix
None listed

What is CVE-2026-112105?

CVE-2026-112105 is a medium-severity vulnerability in GlitterWare Passy, published on 19 Oct 2026.

Official description

A vulnerability has been found in GlitterWare Passy up to 1.10.1. The affected element is the function MyHttpOverrides in the library lib/main.dart of the component TLS Handler. Such manipulation leads to improper certificate validation. The attack may be launched remotely. This attack is characterized by high complexity. The exploitability is described as difficult. Upgrading to version 1.10.2 is sufficient to fix this issue. The name of the patch is 3d48df7cce05e39fa4de1e42768492307f26882e. The affected component should be upgraded.

Weakness: CWE-295, CWE-287

Which versions are affected by CVE-2026-112105?

How do I fix CVE-2026-112105?

No fix has been published for CVE-2026-112105 yet. Limit exposure of the affected software until one is available.

Is CVE-2026-112105 being exploited?

There is no known exploitation of CVE-2026-112105 in the wild and no public exploit code.

Sources

Also known as GHSA-j5q5-6pvc-m68p.

Is CVE-2026-112105 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free