{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-112105 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-112105 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-112105 is a medium-severity vulnerability in GlitterWare Passy, published on 19 Oct 2026."},"fix_prompt":"Check this codebase for CVE-2026-112105 and fix it if it is affected.\n\nWhat it is: CVE-2026-112105 is a medium-severity vulnerability in GlitterWare Passy, published on 19 Oct 2026. \nExploitation: There is no known exploitation of CVE-2026-112105 in the wild and no public exploit code.\n\nAffected product: GlitterWare Passy. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-112105/ (Markdown: https://insights.sbomify.com/CVE-2026-112105/index.md)","id":"CVE-2026-112105","markdown":"https://insights.sbomify.com/CVE-2026-112105/index.md","name":"CVE-2026-112105","record":{"aliases":["GHSA-j5q5-6pvc-m68p"],"analysis":null,"analysis_generated_by":null,"assigner":"VulDB","cpe":[],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:X","version":"4.0"},"cwes":[{"id":"CWE-295","name":"Improper Certificate Validation"},{"id":"CWE-287","name":"Improper Authentication"}],"description":"A vulnerability has been found in GlitterWare Passy up to 1.10.1. The affected element is the function MyHttpOverrides in the library lib/main.dart of the component TLS Handler. Such manipulation leads to improper certificate validation. The attack may be launched remotely. This attack is characterized by high complexity. The exploitability is described as difficult. Upgrading to version 1.10.2 is sufficient to fix this issue. The name of the patch is 3d48df7cce05e39fa4de1e42768492307f26882e. The affected component should be upgraded.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"GlitterWare Passy TLS main.dart MyHttpOverrides certificate validation","id":"CVE-2026-112105","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":null,"year":"2026"},"n_packages":0,"n_references":8,"next":{"headline":"TufayelLUS TikTok-Video-Downloader-PHP TLS index.php certificate validation","id":"CVE-2026-112106"},"packages":[],"prev":{"headline":"eremef bandcamp-player Remote Control Server database.ts missing authentication","id":"CVE-2026-112104"},"products":["Passy"],"published":"2026-10-19","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-19","vendors":["GlitterWare"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2026-112105/"}