# CVE-2026-112105: GlitterWare Passy TLS main.dart MyHttpOverrides certificate validation


- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:X`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 19 Oct 2026
- **Updated:** 19 Oct 2026
- **Also known as:** GHSA-j5q5-6pvc-m68p

## What is CVE-2026-112105?

CVE-2026-112105 is a medium-severity vulnerability in GlitterWare Passy, published on 19 Oct 2026. 

### Official description

A vulnerability has been found in GlitterWare Passy up to 1.10.1. The affected element is the function MyHttpOverrides in the library lib/main.dart of the component TLS Handler. Such manipulation leads to improper certificate validation. The attack may be launched remotely. This attack is characterized by high complexity. The exploitability is described as difficult. Upgrading to version 1.10.2 is sufficient to fix this issue. The name of the patch is 3d48df7cce05e39fa4de1e42768492307f26882e. The affected component should be upgraded.

Weakness: CWE-295 (Improper Certificate Validation), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-112105?


## How do I fix CVE-2026-112105?

No fix has been published for CVE-2026-112105 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-112105 being exploited?

There is no known exploitation of CVE-2026-112105 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-112105 and fix it if it is affected.

What it is: CVE-2026-112105 is a medium-severity vulnerability in GlitterWare Passy, published on 19 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-112105 in the wild and no public exploit code.

Affected product: GlitterWare Passy. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-112105/ (Markdown: https://insights.sbomify.com/CVE-2026-112105/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-112105
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-112105
- OSV: https://osv.dev/vulnerability/CVE-2026-112105

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-112105/
Summaries are generated and may contain mistakes; the official description above is the record.
