# CVE-2026-112147: ai-genius-automations octoally index.ts information disclosure


- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 19 Oct 2026
- **Updated:** 19 Oct 2026
- **Also known as:** GHSA-mc9q-gx24-2r44

## What is CVE-2026-112147?

CVE-2026-112147 is a medium-severity vulnerability in ai-genius-automations octoally, published on 19 Oct 2026. 

### Official description

A vulnerability was found in ai-genius-automations octoally up to 1.0.87. The impacted element is an unknown function of the file server/src/index.ts. Performing a manipulation of the argument path results in information disclosure. The attack may be initiated remotely. The exploit has been made public and could be used. Upgrading to version 1.0.88 is sufficient to resolve this issue. The patch is named 3898085c4e701be21377ebd9e91e10b941e47168. It is recommended to upgrade the affected component.

Weakness: CWE-284 (Improper Access Control), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-112147?


## How do I fix CVE-2026-112147?

No fix has been published for CVE-2026-112147 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-112147 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-112147 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-112147 and fix it if it is affected.

What it is: CVE-2026-112147 is a medium-severity vulnerability in ai-genius-automations octoally, published on 19 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-112147 exists.

Affected product: ai-genius-automations octoally. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-112147/ (Markdown: https://insights.sbomify.com/CVE-2026-112147/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-112147
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-112147
- OSV: https://osv.dev/vulnerability/CVE-2026-112147

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-112147/
Summaries are generated and may contain mistakes; the official description above is the record.
