# CVE-2026-112362: @fastify/express vulnerable to path-scoped middleware bypass via absolute-form request targets


- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 27 Oct 2026
- **Updated:** 27 Oct 2026
- **Also known as:** GHSA-6h42-57hq-9746

## What is CVE-2026-112362?

CVE-2026-112362 is a critical vulnerability in @fastify/express, published on 27 Oct 2026. 

### Official description

@fastify/express is a Fastify plugin that runs Express middleware inside Fastify. In versions 4.0.5 through 4.0.8, when Fastify runs with the non-default ignoreDuplicateSlashes option enabled, the plugin matches path-scoped Express middleware against a URL whose duplicate-slash normalization has also collapsed the separator after an absolute-form request target's scheme, so Fastify's router resolves the request to the scoped path and runs the handler while the Express layer no longer sees that path. As a result, a request using an absolute-form target can reach a handler on a scoped route such as an admin path while the middleware for authentication, authorization, or rate limiting is skipped. An unauthenticated attacker needs only the non-default ignoreDuplicateSlashes option to be enabled. The issue is fixed in @fastify/express 4.0.9, and users should upgrade to 4.0.9 or later. As a workaround, enforce authentication in a Fastify hook such as preHandler that runs after the router resolves the request, or leave ignoreDuplicateSlashes at its default.

Weakness: CWE-436 (Interpretation Conflict)

## Which versions are affected by CVE-2026-112362?


## How do I fix CVE-2026-112362?

No fix has been published for CVE-2026-112362 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-112362 being exploited?

There is no known exploitation of CVE-2026-112362 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-112362 and fix it if it is affected.

What it is: CVE-2026-112362 is a critical vulnerability in @fastify/express, published on 27 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-112362 in the wild and no public exploit code.

Affected product: @fastify/express. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-112362/ (Markdown: https://insights.sbomify.com/CVE-2026-112362/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-112362
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-112362
- OSV: https://osv.dev/vulnerability/CVE-2026-112362

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-112362/
Summaries are generated and may contain mistakes; the official description above is the record.
