# CVE-2026-112403: Pillow: Heap buffer overflow in ImagingJpegDecode

> Heap buffer overflow in Pillow's JPEG decoder allows attackers to corrupt memory, crash the process, or execute code via crafted images.

- **Severity:** Critical 9.2 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Oct 2026
- **Updated:** 22 Oct 2026
- **Also known as:** BIT-pillow-2026-112403, DEBIAN-CVE-2026-112403, ECHO-7dc8-65d8-fff5, GHSA-8g5g-8vmr-9782, PYSEC-2026-4332, ROOT-APP-PYPI-CVE-2026-112403, UBUNTU-CVE-2026-112403

## What is CVE-2026-112403?

CVE-2026-112403 is a critical memory corruption vulnerability in Python Pillow, published on 19 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Pillow is a Python imaging library. Prior to 13.0.0, Pillow's JPEG decoder can write a full-width scanline into a buffer sized for a requested draft scale. ImagingJpegDecode does not verify libjpeg's actual output width and component count after scaling is requested, and an 8-bit lossless SOF3 JPEG decoded by a build linked to libjpeg-turbo 3.x can ignore the requested downscaling geometry. An attacker can supply such a JPEG to an application that uses draft() or thumbnail() to request downscaling. This can corrupt heap memory, crash the process, or potentially allow code execution. Older libjpeg-turbo 2.x and IJG builds reject the SOF3 input. This issue is fixed in version 13.0.0.

Weakness: CWE-122 (Heap-based Buffer Overflow)

## Which versions are affected by CVE-2026-112403?

4 open source packages ship an affected version, including pillow and Pillow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pillow` | Bitnami | All versions | 13.0.0 |
| `pillow` | PyPI | All versions | 13.0.0 |
| `pillow` | PyPI | All versions | 13.0.0 |
| `Pillow` | PyPI | All versions | 13.0.0 |

Products: Python Pillow.

## How do I fix CVE-2026-112403?

Upgrade pillow to 13.0.0 or later.

## Is CVE-2026-112403 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-112403 exists.

Public exploit code:

- CVE-2026-112403: Pillow heap buffer overflow in ImagingJpegDecode via lossless JPEG thumbnail. One POST, 100% crash rate. (github_poc): https://github.com/al4n4n/CVE-2026-112403

## Other vulnerabilities in Python Pillow

- [CVE-2014-3007](https://insights.sbomify.com/CVE-2014-3007/): Pillow command injection (critical 10.0)
- [CVE-2026-96639](https://insights.sbomify.com/CVE-2026-96639/): Pillow multi-frame loaders can reuse stale native image storage after mode transitions (critical 9.8)
- [CVE-2022-30595](https://insights.sbomify.com/CVE-2022-30595/): Buffer over-flow in Pillow (critical 9.8)
- [CVE-2021-25289](https://insights.sbomify.com/CVE-2021-25289/): Out of bounds write in Pillow (critical 9.8)
- [CVE-2016-4009](https://insights.sbomify.com/CVE-2016-4009/): Pillow Integer overflow in ImagingResampleHorizontal (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-112403 and fix it if it is affected.

What it is: CVE-2026-112403 is a critical memory corruption vulnerability in Python Pillow, published on 19 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-112403 exists.

Affected packages and fixed versions:
- pillow (Bitnami): affected all versions; fixed in 13.0.0
- pillow (PyPI): affected all versions; fixed in 13.0.0
- pillow (PyPI): affected all versions; fixed in 13.0.0
- Pillow (PyPI): affected all versions; fixed in 13.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-112403/ (Markdown: https://insights.sbomify.com/CVE-2026-112403/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-112403
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-112403
- OSV: https://osv.dev/vulnerability/CVE-2026-112403

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-112403/
Summaries are generated and may contain mistakes; the official description above is the record.
