# CVE-2026-112408: Missing bucket ownership verification in Amazon SageMaker Python SDK default_bucket()


- **Severity:** Critical 9.4 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 21 Oct 2026
- **Updated:** 21 Oct 2026
- **Also known as:** GHSA-5rx8-8fr2-f855

## What is CVE-2026-112408?

CVE-2026-112408 is a critical vulnerability in AWS Amazon SageMaker Python SDK, published on 21 Oct 2026. 

### Official description

Missing verification of source of a communication channel in the default_bucket() function in Amazon SageMaker Python SDK V3 before 3.10.0 and V2 before 2.257.3 might allow remote actors to achieve code execution in the target SageMaker execution environment and obtain IAM credentials via pre-creation of a predictably named S3 bucket that the SDK uses without ownership validation.

To remediate this issue, users should upgrade to Amazon SageMaker Python SDK 3.10.0 (V3) or 2.257.3 (V2).

Weakness: CWE-940 (Improper Verification of Source of a Communication Channel)

## Which versions are affected by CVE-2026-112408?


## How do I fix CVE-2026-112408?

No fix has been published for CVE-2026-112408 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-112408 being exploited?

There is no known exploitation of CVE-2026-112408 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-112408 and fix it if it is affected.

What it is: CVE-2026-112408 is a critical vulnerability in AWS Amazon SageMaker Python SDK, published on 21 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-112408 in the wild and no public exploit code.

Affected product: AWS Amazon SageMaker Python SDK. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-112408/ (Markdown: https://insights.sbomify.com/CVE-2026-112408/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-112408
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-112408
- OSV: https://osv.dev/vulnerability/CVE-2026-112408

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-112408/
Summaries are generated and may contain mistakes; the official description above is the record.
