CVE-2026-112712 @fastify/middie vulnerable to path-scoped middleware bypass via scope prefix mismatch
- Exploited in the wild
- Not known
- Fix
- None listed
What is CVE-2026-112712?
CVE-2026-112712 is a critical vulnerability in @fastify/middie, published on 20 Oct 2026.
Official description
@fastify/middie is the Express-style middleware engine for Fastify. In versions from 9.0.0 through 9.3.5, the use() function joined a path-scoped middleware's mount path to the plugin scope prefix in a way that could diverge from the path Fastify's router serves, most often when the scope prefix ended in a slash, and also for array mount paths and for mount paths written without a leading slash. When the two paths disagreed, the middleware was silently skipped while the route handler still ran, so path-scoped middleware such as authentication, authorization, or rate limiting could be bypassed by a single unauthenticated request. The issue is fixed in @fastify/middie 9.3.6, and users should upgrade to 9.3.6 or later. As a workaround, enforce authorization in a Fastify hook such as preHandler that runs after the router has resolved the request.
Weakness: CWE-436
Which versions are affected by CVE-2026-112712?
How do I fix CVE-2026-112712?
No fix has been published for CVE-2026-112712 yet. Limit exposure of the affected software until one is available.
Is CVE-2026-112712 being exploited?
There is no known exploitation of CVE-2026-112712 in the wild and no public exploit code.
Sources
Also known as GHSA-5p92-8765-9fv8.