# CVE-2026-112712: @fastify/middie vulnerable to path-scoped middleware bypass via scope prefix mismatch


- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 20 Oct 2026
- **Updated:** 20 Oct 2026
- **Also known as:** GHSA-5p92-8765-9fv8

## What is CVE-2026-112712?

CVE-2026-112712 is a critical vulnerability in @fastify/middie, published on 20 Oct 2026. 

### Official description

@fastify/middie is the Express-style middleware engine for Fastify. In versions from 9.0.0 through 9.3.5, the use() function joined a path-scoped middleware's mount path to the plugin scope prefix in a way that could diverge from the path Fastify's router serves, most often when the scope prefix ended in a slash, and also for array mount paths and for mount paths written without a leading slash. When the two paths disagreed, the middleware was silently skipped while the route handler still ran, so path-scoped middleware such as authentication, authorization, or rate limiting could be bypassed by a single unauthenticated request. The issue is fixed in @fastify/middie 9.3.6, and users should upgrade to 9.3.6 or later. As a workaround, enforce authorization in a Fastify hook such as preHandler that runs after the router has resolved the request.

Weakness: CWE-436 (Interpretation Conflict)

## Which versions are affected by CVE-2026-112712?


## How do I fix CVE-2026-112712?

No fix has been published for CVE-2026-112712 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-112712 being exploited?

There is no known exploitation of CVE-2026-112712 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-112712 and fix it if it is affected.

What it is: CVE-2026-112712 is a critical vulnerability in @fastify/middie, published on 20 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-112712 in the wild and no public exploit code.

Affected product: @fastify/middie. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-112712/ (Markdown: https://insights.sbomify.com/CVE-2026-112712/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-112712
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-112712
- OSV: https://osv.dev/vulnerability/CVE-2026-112712

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-112712/
Summaries are generated and may contain mistakes; the official description above is the record.
