CVE-2026-112768 Parse Server before 8.6.99 and 9.x before 9.10.3-alpha.2 Information Disclosure via User Update
An unauthorized attacker can confirm valid usernames, emails, and potentially passwords by exploiting flawed authorization checks during user updates.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-112768?
CVE-2026-112768 is a medium-severity vulnerability in parse-community parse-server, published on 19 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Parse Server before 8.6.99 and 9.0.0 before 9.10.3-alpha.2 evaluates checks against the target account during a user update before authorizing the caller, and reflects their outcome in the response. An unauthorized caller, with or without a session, can confirm guessed usernames or emails and, when passwordPolicy.maxPasswordHistory or doNotAllowUsername is set, guessed current or previous passwords, bypassing account lockout.
Weakness: CWE-863
Which versions are affected by CVE-2026-112768?
1 open source package ship an affected version, including parse.
| Package | Affected | Fixed in |
|---|---|---|
parse Bitnami | All versions | 8.6.99, 9.10.3 |
How do I fix CVE-2026-112768?
Upgrade parse to a fixed version for your release line: 8.6.99 or 9.10.3.
Is CVE-2026-112768 being exploited?
There is no known exploitation of CVE-2026-112768 in the wild and no public exploit code.
Sources
Also known as BIT-parse-2026-112768, GHSA-p49q-9w65-f9p7, GHSA-w8m9-f3qj-3xfx.