{"answers":{"affected":"1 open source package ship an affected version, including parse.","exploited":"There is no known exploitation of CVE-2026-112768 in the wild and no public exploit code.","fix":"Upgrade parse to a fixed version for your release line: 8.6.99 or 9.10.3.","what":"CVE-2026-112768 is a medium-severity vulnerability in parse-community parse-server, published on 19 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-112768 and fix it if it is affected.\n\nWhat it is: CVE-2026-112768 is a medium-severity vulnerability in parse-community parse-server, published on 19 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-112768 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- parse (Bitnami): affected all versions; fixed in 8.6.99, 9.10.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-112768/ (Markdown: https://insights.sbomify.com/CVE-2026-112768/index.md)","id":"CVE-2026-112768","markdown":"https://insights.sbomify.com/CVE-2026-112768/index.md","name":"CVE-2026-112768","record":{"aliases":["BIT-parse-2026-112768","GHSA-p49q-9w65-f9p7","GHSA-w8m9-f3qj-3xfx"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Parse Server","requires_auth":"none","summary":"An unauthorized attacker can confirm valid usernames, emails, and potentially passwords by exploiting flawed authorization checks during user updates.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"Parse Server before 8.6.99 and 9.0.0 before 9.10.3-alpha.2 evaluates checks against the target account during a user update before authorizing the caller, and reflects their outcome in the response. An unauthorized caller, with or without a session, can confirm guessed usernames or emails and, when passwordPolicy.maxPasswordHistory or doNotAllowUsername is set, guessed current or previous passwords, bypassing account lockout.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Parse Server before 8.6.99 and 9.x before 9.10.3-alpha.2 Information Disclosure via User Update","id":"CVE-2026-112768","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"information_disclosure","year":"2026"},"n_packages":1,"n_references":2,"next":{"headline":"Parse Server before 8.6.98 and 9.x before 9.10.3-alpha.1 Session Class-Level Permission Bypass","id":"CVE-2026-112769"},"packages":[{"ecosystem":"Bitnami","fixed":["8.6.99","9.10.3"],"introduced":["0","9.0.0"],"last_affected":[],"package":"parse","purl":"pkg:bitnami/parse","source":"BIT-parse-2026-112768"}],"prev":{"headline":"@fastify/middie vulnerable to path-scoped middleware bypass via scope prefix mismatch","id":"CVE-2026-112712"},"products":["parse-server"],"published":"2026-10-19","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-19","vendors":["parse-community"]},"summary":"An unauthorized attacker can confirm valid usernames, emails, and potentially passwords by exploiting flawed authorization checks during user updates.","url":"https://insights.sbomify.com/CVE-2026-112768/"}