# CVE-2026-112768: Parse Server before 8.6.99 and 9.x before 9.10.3-alpha.2 Information Disclosure via User Update

> An unauthorized attacker can confirm valid usernames, emails, and potentially passwords by exploiting flawed authorization checks during user updates.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Oct 2026
- **Updated:** 19 Oct 2026
- **Also known as:** BIT-parse-2026-112768, GHSA-p49q-9w65-f9p7, GHSA-w8m9-f3qj-3xfx

## What is CVE-2026-112768?

CVE-2026-112768 is a medium-severity vulnerability in parse-community parse-server, published on 19 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Parse Server before 8.6.99 and 9.0.0 before 9.10.3-alpha.2 evaluates checks against the target account during a user update before authorizing the caller, and reflects their outcome in the response. An unauthorized caller, with or without a session, can confirm guessed usernames or emails and, when passwordPolicy.maxPasswordHistory or doNotAllowUsername is set, guessed current or previous passwords, bypassing account lockout.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-112768?

1 open source package ship an affected version, including parse.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `parse` | Bitnami | All versions | 8.6.99, 9.10.3 |

## How do I fix CVE-2026-112768?

Upgrade parse to a fixed version for your release line: 8.6.99 or 9.10.3.

## Is CVE-2026-112768 being exploited?

There is no known exploitation of CVE-2026-112768 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-112768 and fix it if it is affected.

What it is: CVE-2026-112768 is a medium-severity vulnerability in parse-community parse-server, published on 19 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-112768 in the wild and no public exploit code.

Affected packages and fixed versions:
- parse (Bitnami): affected all versions; fixed in 8.6.99, 9.10.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-112768/ (Markdown: https://insights.sbomify.com/CVE-2026-112768/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-112768
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-112768
- OSV: https://osv.dev/vulnerability/CVE-2026-112768

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-112768/
Summaries are generated and may contain mistakes; the official description above is the record.
