# CVE-2026-112880: CRLF injection in Proxy-Authorization header built from proxy_auth_fun in hackney


- **Severity:** Low 2.1 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 26 Oct 2026
- **Updated:** 26 Oct 2026
- **Also known as:** EEF-CVE-2026-112880, GHSA-5qp8-qrjx-2669

## What is CVE-2026-112880?

CVE-2026-112880 is a low-severity vulnerability in benoitc hackney, published on 26 Oct 2026. 

### Official description

Improper Neutralization of CRLF Sequences in HTTP Headers ('HTTP Request/Response Splitting') vulnerability in hackney_http_connect in benoitc hackney allows HTTP Request Splitting via the value a proxy_auth_fun callback returns. After a 407 response from an HTTP CONNECT proxy, hackney_http_connect:handle_proxy_auth/11 calls the caller's proxy_auth_fun with the status code and the response headers and writes the returned binary into the Proxy-Authorization line of the CONNECT retry without checking it. A CR, LF or NUL byte in that value adds header lines to the request sent to the proxy.

The value is attacker-influenced when the callback derives it from untrusted data, for example from the proxy's challenge headers. Other caller-supplied values on the CONNECT path, such as the target host and the request headers, were already checked for control bytes.

This issue affects hackney: from 2.0.0 before 4.9.0.

Weakness: CWE-113 (Improper Neutralization of CRLF Sequences in HTTP Headers)

## Which versions are affected by CVE-2026-112880?

1 open source package ship an affected version, including hackney.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `hackney` | Hex | From 2.0.0 | 4.9.0 |

## How do I fix CVE-2026-112880?

Upgrade hackney to 4.9.0 or later.

## Is CVE-2026-112880 being exploited?

There is no known exploitation of CVE-2026-112880 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-112880 and fix it if it is affected.

What it is: CVE-2026-112880 is a low-severity vulnerability in benoitc hackney, published on 26 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-112880 in the wild and no public exploit code.

Affected packages and fixed versions:
- hackney (Hex): affected from 2.0.0; fixed in 4.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-112880/ (Markdown: https://insights.sbomify.com/CVE-2026-112880/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-112880
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-112880
- OSV: https://osv.dev/vulnerability/CVE-2026-112880

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-112880/
Summaries are generated and may contain mistakes; the official description above is the record.
