# CVE-2026-112895: Pillow: Unbounded recursion parsing a PDF page tree or trailer chain (incomplete fix for CVE-2026-42310)

> Attackers can cause denial of service in applications using Pillow by supplying malicious PDFs that trigger excessive resource consumption during append operations.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Oct 2026
- **Updated:** 20 Oct 2026
- **Also known as:** BIT-pillow-2026-112895, DEBIAN-CVE-2026-112895, ECHO-96b2-16e7-d7c9, GHSA-p4wg-p73j-c528, ROOT-APP-PYPI-CVE-2026-112895, UBUNTU-CVE-2026-112895

## What is CVE-2026-112895?

CVE-2026-112895 is a high-severity denial of service vulnerability in Python Pillow, published on 19 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Pillow is a Python imaging library. From 5.1.0 until 13.0.0, Pillow can exhaust resources while parsing an existing PDF during an append operation. PdfParser follows page-tree child references without cycle or duplication tracking and follows previous-trailer chains with only an exact repeated-offset guard, so deep or cyclic page trees and long chains of unique trailer offsets can exhaust the Python stack. Repeated non-cyclic /Kids references can also cause super-linear CPU and memory use. An attacker can supply such a PDF to an application that calls Image.save with PDF append enabled. This can raise an uncaught RecursionError or consume excessive CPU and memory before output is written, causing denial of service. This issue is fixed in version 13.0.0.

Weakness: CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2026-112895?

3 open source packages ship an affected version, including pillow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pillow` | Bitnami | From 5.1.0 | 13.0.0 |
| `pillow` | PyPI | From 5.1.0 | 13.0.0 |
| `pillow` | PyPI | From 5.1.0 | 13.0.0 |

Products: Python Pillow.

## How do I fix CVE-2026-112895?

Upgrade pillow to 13.0.0 or later.

## Is CVE-2026-112895 being exploited?

There is no known exploitation of CVE-2026-112895 in the wild and no public exploit code.

## Other vulnerabilities in Python Pillow

- [CVE-2014-3007](https://insights.sbomify.com/CVE-2014-3007/): Pillow command injection (critical 10.0)
- [CVE-2026-96639](https://insights.sbomify.com/CVE-2026-96639/): Pillow multi-frame loaders can reuse stale native image storage after mode transitions (critical 9.8)
- [CVE-2022-30595](https://insights.sbomify.com/CVE-2022-30595/): Buffer over-flow in Pillow (critical 9.8)
- [CVE-2021-25289](https://insights.sbomify.com/CVE-2021-25289/): Out of bounds write in Pillow (critical 9.8)
- [CVE-2016-4009](https://insights.sbomify.com/CVE-2016-4009/): Pillow Integer overflow in ImagingResampleHorizontal (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-112895 and fix it if it is affected.

What it is: CVE-2026-112895 is a high-severity denial of service vulnerability in Python Pillow, published on 19 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-112895 in the wild and no public exploit code.

Affected packages and fixed versions:
- pillow (Bitnami): affected from 5.1.0; fixed in 13.0.0
- pillow (PyPI): affected from 5.1.0; fixed in 13.0.0
- pillow (PyPI): affected from 5.1.0; fixed in 13.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-112895/ (Markdown: https://insights.sbomify.com/CVE-2026-112895/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-112895
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-112895
- OSV: https://osv.dev/vulnerability/CVE-2026-112895

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-112895/
Summaries are generated and may contain mistakes; the official description above is the record.
