# CVE-2026-112944: launch-editor: Editor CLI flag misinterpretation causing arbitrary command execution for some editors


- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 20 Oct 2026
- **Updated:** 20 Oct 2026
- **Also known as:** ECHO-d59c-c98f-21d4, GHSA-r825-w8mm-5pxw, MINI-36pq-v2w2-q96x, MINI-4v4q-w2rg-r3mq, MINI-5m26-256q-284c, MINI-6r8j-cqqj-xp8p, MINI-76h6-h4w8-7qgx, MINI-g43q-vfq2-jwg9

## What is CVE-2026-112944?

CVE-2026-112944 is a medium-severity vulnerability in vitejs launch-editor, published on 20 Oct 2026. 

### Official description

launch-editor allows users to open files with line numbers in editor from Node.js. Prior to 2.14.2, when an attacker can create a filesystem entry beginning with plus or minus in the working directory, an affected editor is selected, and the path can remain relative or is converted to a relative WSL path, launchEditor forwards the path without forcing it to be interpreted as a positional filename. Editor option parsing then treats the attacker-controlled filename as a command-line flag, which can cause unintended file overwrite or arbitrary command execution by the selected editor. The affected editors are Vim and gVim, MacVim, Emacs and Emacsclient, and Notepad++ when a plugin exposes dangerous operations; WSL path conversion keeps Vite and newer middleware callers exposed. This issue is fixed in version 2.14.2.

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command)

## Which versions are affected by CVE-2026-112944?

14 open source packages ship an affected version, including launch-editor, vite and vite-plus.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `launch-editor` | npm | All versions | 2.14.2 |
| `launch-editor` | npm | All versions | 2.14.2 |
| `vite` | npm | All versions | 6.4.4 |
| `vite` | npm | All versions | 6.4.4 |
| `vite` | npm | From 7.0.0 | 7.3.7 |
| `vite` | npm | From 7.0.0 | 7.3.7 |
| `vite` | npm | From 8.0.0 | 8.1.6 |
| `vite` | npm | From 8.0.0 | 8.1.6 |
| `vite` | npm | From 8.2.0 | 8.2.4 |
| `vite` | npm | From 8.2.0 | 8.2.4 |
| `vite` | npm | From 8.3.0 | 8.3.3 |
| `vite` | npm | From 8.3.0 | 8.3.3 |
| `vite-plus` | npm | All versions | 1.1.0 |
| `vite-plus` | npm | All versions | 1.1.0 |

## How do I fix CVE-2026-112944?

Upgrade launch-editor to 2.14.2 or later.

## Is CVE-2026-112944 being exploited?

There is no known exploitation of CVE-2026-112944 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-112944 and fix it if it is affected.

What it is: CVE-2026-112944 is a medium-severity vulnerability in vitejs launch-editor, published on 20 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-112944 in the wild and no public exploit code.

Affected packages and fixed versions:
- launch-editor (npm): affected all versions; fixed in 2.14.2
- launch-editor (npm): affected all versions; fixed in 2.14.2
- vite (npm): affected all versions; fixed in 6.4.4
- vite (npm): affected all versions; fixed in 6.4.4
- vite (npm): affected from 7.0.0; fixed in 7.3.7
- vite (npm): affected from 7.0.0; fixed in 7.3.7
- vite (npm): affected from 8.0.0; fixed in 8.1.6
- vite (npm): affected from 8.0.0; fixed in 8.1.6
- vite (npm): affected from 8.2.0; fixed in 8.2.4
- vite (npm): affected from 8.2.0; fixed in 8.2.4
- vite (npm): affected from 8.3.0; fixed in 8.3.3
- vite (npm): affected from 8.3.0; fixed in 8.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-112944/ (Markdown: https://insights.sbomify.com/CVE-2026-112944/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-112944
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-112944
- OSV: https://osv.dev/vulnerability/CVE-2026-112944

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-112944/
Summaries are generated and may contain mistakes; the official description above is the record.
