CVE-2026-112945 Vite: Cross origin script execution through Vite custom middleware
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2026-112945?
CVE-2026-112945 is a low-severity vulnerability in vitejs vite, published on 20 Oct 2026.
Official description
Vite is a frontend tooling framework for JavaScript. Prior to 6.4.4, 7.3.7, 8.1.6, 8.2.4, and 8.3.3, applications using custom middleware are vulnerable when they pass an unchanged browser request URL to server.transformIndexHtml. getHtmlFilename uses the query-bearing request URL to resolve an existing local file while preserving attacker-supplied leading slashes in the generated proxy module URL. If the transformed HTML contains an inline module script and a victim browser loads the crafted development-server page, the leading double slash makes the browser fetch and execute an attacker-controlled module in the Vite-served page. This execution can expose sensitive page data or permit critical actions available to the affected application. This issue is fixed in versions 6.4.4, 7.3.7, 8.1.6, 8.2.4, and 8.3.3.
Weakness: CWE-80
Which versions are affected by CVE-2026-112945?
12 open source packages ship an affected version, including vite and vite-plus.
| Package | Affected | Fixed in |
|---|---|---|
vite npm | All versions | 6.4.4 |
vite npm | All versions | 6.4.4 |
vite npm | From 7.0.0 | 7.3.7 |
vite npm | From 7.0.0 | 7.3.7 |
vite npm | From 8.0.0 | 8.1.6 |
vite npm | From 8.0.0 | 8.1.6 |
6 more packages
vite npm | From 8.2.0 | 8.2.4 |
vite npm | From 8.2.0 | 8.2.4 |
vite npm | From 8.3.0 | 8.3.3 |
vite npm | From 8.3.0 | 8.3.3 |
vite-plus npm | All versions | 1.1.0 |
vite-plus npm | All versions | 1.1.0 |
How do I fix CVE-2026-112945?
Upgrade vite to a fixed version for your release line: 6.4.4, 7.3.7, 8.1.6 or 8.2.4.
Is CVE-2026-112945 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-112945 exists.
Sources
Also known as ECHO-2b64-1afa-7929, GHSA-9jrq-w75r-8gcw, UBUNTU-CVE-2026-112945.