# CVE-2026-112948: Vitest: Servers misapply `server.fs.deny`, serving `.env`, private keys, `.git`, and the API token file


- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 20 Oct 2026
- **Updated:** 20 Oct 2026
- **Also known as:** GHSA-p458-7748-mcp3

## What is CVE-2026-112948?

CVE-2026-112948 is a medium-severity vulnerability in @vitest browser, published on 20 Oct 2026. 

### Official description

Vitest is a testing framework powered by Vite. From 5.0.0-beta.6 until 5.0.5, Vitest dev servers can misapply server.fs.deny because project servers replace Vite's defaults and the root server adds .vitest-secret-token after Vite compiles its matcher. An attacker who can reach an affected UI, Browser Mode, or API server can read denied project files or the fallback API token at node_modules/.vitest/.vitest-secret-token, and Browser Mode with test.projects can expose JavaScript-compatible .env values through a malicious website. This issue is fixed in version 5.0.5.

Weakness: CWE-552 (Files or Directories Accessible to External Parties), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-112948?

6 open source packages ship an affected version, including @vitest/browser, @vitest/ui and vite-plus.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@vitest/browser` | npm | From 5.0.0-beta.6 | 5.0.5 |
| `@vitest/browser` | npm | From 5.0.0-beta.6 | 5.0.5 |
| `@vitest/ui` | npm | From 5.0.0-beta.6 | 5.0.5 |
| `@vitest/ui` | npm | From 5.0.0-beta.6 | 5.0.5 |
| `vite-plus` | npm | From 1.0.0-rc.0 | 1.3.0 |
| `vite-plus` | npm | From 1.0.0-rc.0 | 1.3.0 |

## How do I fix CVE-2026-112948?

Upgrade @vitest/browser to 5.0.5 or later.

## Is CVE-2026-112948 being exploited?

There is no known exploitation of CVE-2026-112948 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-112948 and fix it if it is affected.

What it is: CVE-2026-112948 is a medium-severity vulnerability in @vitest browser, published on 20 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-112948 in the wild and no public exploit code.

Affected packages and fixed versions:
- @vitest/browser (npm): affected from 5.0.0-beta.6; fixed in 5.0.5
- @vitest/browser (npm): affected from 5.0.0-beta.6; fixed in 5.0.5
- @vitest/ui (npm): affected from 5.0.0-beta.6; fixed in 5.0.5
- @vitest/ui (npm): affected from 5.0.0-beta.6; fixed in 5.0.5
- vite-plus (npm): affected from 1.0.0-rc.0; fixed in 1.3.0
- vite-plus (npm): affected from 1.0.0-rc.0; fixed in 1.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-112948/ (Markdown: https://insights.sbomify.com/CVE-2026-112948/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-112948
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-112948
- OSV: https://osv.dev/vulnerability/CVE-2026-112948

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-112948/
Summaries are generated and may contain mistakes; the official description above is the record.
