# CVE-2026-112951: ApostropheCMS: Color field validation bypass allows stored XSS via HTML appended after rgb()/hsl() prefix


- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 20 Oct 2026
- **Updated:** 20 Oct 2026
- **Also known as:** GHSA-vmgj-9cwm-cf3h

## What is CVE-2026-112951?

CVE-2026-112951 is a medium-severity vulnerability in apostrophecms apostrophe, published on 20 Oct 2026. 

### Official description

ApostropheCMS is an open-source Node.js content management system. Prior to 4.34.0, the color field accepts trailing content after a valid rgb() or hsl() prefix because its TinyColor validation does not require the entire value to match a color. An authenticated user with edit rights can store arbitrary HTML after a valid color prefix. When the stored value is rendered, the payload executes, resulting in stored XSS. This issue is fixed in version 4.34.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-112951?

2 open source packages ship an affected version, including apostrophe.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apostrophe` | npm | All versions | 4.34.0 |
| `apostrophe` | npm | All versions | 4.34.0 |

## How do I fix CVE-2026-112951?

Upgrade apostrophe to 4.34.0 or later.

## Is CVE-2026-112951 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-112951 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-112951 and fix it if it is affected.

What it is: CVE-2026-112951 is a medium-severity vulnerability in apostrophecms apostrophe, published on 20 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-112951 exists.

Affected packages and fixed versions:
- apostrophe (npm): affected all versions; fixed in 4.34.0
- apostrophe (npm): affected all versions; fixed in 4.34.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-112951/ (Markdown: https://insights.sbomify.com/CVE-2026-112951/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-112951
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-112951
- OSV: https://osv.dev/vulnerability/CVE-2026-112951

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-112951/
Summaries are generated and may contain mistakes; the official description above is the record.
