# CVE-2026-112952: ApostropheCMS: POST /api/v1/@apostrophecms/doc/slugTaken discloses existence of private/admin-only content to any authenticated user


- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 20 Oct 2026
- **Updated:** 21 Oct 2026
- **Also known as:** GHSA-f66c-mpj2-3r8h

## What is CVE-2026-112952?

CVE-2026-112952 is a medium-severity vulnerability in apostrophecms apostrophe, published on 20 Oct 2026. 

### Official description

ApostropheCMS is an open-source Node.js content management system. Prior to 4.34.0, 'POST /api/v1/@apostrophecms/doc/slugTaken' with body { "slug": "target-slug" } returns a boolean indicating whether a slug is in use across all document types and visibility levels, with no permission or type filter. Any logged-in user (including editors) can enumerate the slug space of private pages, drafts, and archived content. This issue is fixed in version 4.34.0.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-112952?

2 open source packages ship an affected version, including apostrophe.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apostrophe` | npm | All versions | 4.34.0 |
| `apostrophe` | npm | All versions | 4.34.0 |

## How do I fix CVE-2026-112952?

Upgrade apostrophe to 4.34.0 or later.

## Is CVE-2026-112952 being exploited?

There is no known exploitation of CVE-2026-112952 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-112952 and fix it if it is affected.

What it is: CVE-2026-112952 is a medium-severity vulnerability in apostrophecms apostrophe, published on 20 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-112952 in the wild and no public exploit code.

Affected packages and fixed versions:
- apostrophe (npm): affected all versions; fixed in 4.34.0
- apostrophe (npm): affected all versions; fixed in 4.34.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-112952/ (Markdown: https://insights.sbomify.com/CVE-2026-112952/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-112952
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-112952
- OSV: https://osv.dev/vulnerability/CVE-2026-112952

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-112952/
Summaries are generated and may contain mistakes; the official description above is the record.
