# CVE-2026-112953: ApostropheCMS: Exposure of Sensitive Information via predictable export filenames


- **Severity:** Medium 6.0 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 20 Oct 2026
- **Updated:** 20 Oct 2026
- **Also known as:** GHSA-5gc8-frw3-3vqm

## What is CVE-2026-112953?

CVE-2026-112953 is a medium-severity vulnerability in @apostrophecms apostrophe, published on 20 Oct 2026. 

### Official description

ApostropheCMS is an open-source Node.js content management system. Prior to 3.7.1 of the import-export module, predictable export archive filenames allow an unauthenticated requester to download another user's export from publicly readable export storage before the archive expires or is removed. A user with export permission must first create the archive, and sites with exports disabled, private upload storage, or authenticated upload delivery are not exposed through this network-download path. This issue is fixed in version 3.7.1.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-112953?

2 open source packages ship an affected version, including @apostrophecms/import-export.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@apostrophecms/import-export` | npm | All versions | 3.7.1 |
| `@apostrophecms/import-export` | npm | All versions | 3.7.1 |

## How do I fix CVE-2026-112953?

Upgrade @apostrophecms/import-export to 3.7.1 or later.

## Is CVE-2026-112953 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-112953 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-112953 and fix it if it is affected.

What it is: CVE-2026-112953 is a medium-severity vulnerability in @apostrophecms apostrophe, published on 20 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-112953 exists.

Affected packages and fixed versions:
- @apostrophecms/import-export (npm): affected all versions; fixed in 3.7.1
- @apostrophecms/import-export (npm): affected all versions; fixed in 3.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-112953/ (Markdown: https://insights.sbomify.com/CVE-2026-112953/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-112953
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-112953
- OSV: https://osv.dev/vulnerability/CVE-2026-112953

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-112953/
Summaries are generated and may contain mistakes; the official description above is the record.
