# CVE-2026-112954: ApostropheCMS: Unauthenticated publicApiProjection bypass via search and sort query builders in the public REST API


- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 20 Oct 2026
- **Updated:** 23 Oct 2026
- **Also known as:** GHSA-rqgm-cfrp-4hx8

## What is CVE-2026-112954?

CVE-2026-112954 is a medium-severity vulnerability in apostrophecms apostrophe, published on 20 Oct 2026. 

### Official description

ApostropheCMS is an open-source Node.js content management system. Prior to 4.34.0, a public REST API type that uses publicApiProjection can expose excluded searchable or sortable field information through search membership and sort ordering oracles. Returned fields remain filtered by the projection, so the issue permits targeted inference about hidden values rather than an unrestricted field dump. This issue is fixed in version 4.34.0.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-112954?

2 open source packages ship an affected version, including apostrophe.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apostrophe` | npm | All versions | 4.34.0 |
| `apostrophe` | npm | All versions | 4.34.0 |

## How do I fix CVE-2026-112954?

Upgrade apostrophe to 4.34.0 or later.

## Is CVE-2026-112954 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-112954 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-112954 and fix it if it is affected.

What it is: CVE-2026-112954 is a medium-severity vulnerability in apostrophecms apostrophe, published on 20 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-112954 exists.

Affected packages and fixed versions:
- apostrophe (npm): affected all versions; fixed in 4.34.0
- apostrophe (npm): affected all versions; fixed in 4.34.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-112954/ (Markdown: https://insights.sbomify.com/CVE-2026-112954/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-112954
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-112954
- OSV: https://osv.dev/vulnerability/CVE-2026-112954

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-112954/
Summaries are generated and may contain mistakes; the official description above is the record.
