# CVE-2026-112955: ApostropheCMS: Import archives can exhaust server storage and deny service


- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 20 Oct 2026
- **Updated:** 26 Oct 2026
- **Also known as:** GHSA-9g7p-m758-rp72

## What is CVE-2026-112955?

CVE-2026-112955 is a medium-severity vulnerability in @apostrophecms apostrophe, published on 20 Oct 2026. 

### Official description

ApostropheCMS is an open-source Node.js content management system. Prior to 3.7.1 of the import-export module, an authenticated importer can submit archives whose decompressed bytes, entry count, and entry sizes are not bounded before document-type authorization, and extraction or parsing failures can leave staging and extracted artifacts without unconditional cleanup. The already-hardened pre-authentication and write-error paths are separate, and current end-to-end denial-of-service impact from this residual path remains subject to maintainer validation. This issue is fixed in version 3.7.1.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-112955?

2 open source packages ship an affected version, including @apostrophecms/import-export.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@apostrophecms/import-export` | npm | All versions | 3.7.1 |
| `@apostrophecms/import-export` | npm | All versions | 3.7.1 |

## How do I fix CVE-2026-112955?

Upgrade @apostrophecms/import-export to 3.7.1 or later.

## Is CVE-2026-112955 being exploited?

There is no known exploitation of CVE-2026-112955 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-112955 and fix it if it is affected.

What it is: CVE-2026-112955 is a medium-severity vulnerability in @apostrophecms apostrophe, published on 20 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-112955 in the wild and no public exploit code.

Affected packages and fixed versions:
- @apostrophecms/import-export (npm): affected all versions; fixed in 3.7.1
- @apostrophecms/import-export (npm): affected all versions; fixed in 3.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-112955/ (Markdown: https://insights.sbomify.com/CVE-2026-112955/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-112955
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-112955
- OSV: https://osv.dev/vulnerability/CVE-2026-112955

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-112955/
Summaries are generated and may contain mistakes; the official description above is the record.
