# CVE-2026-112956: ApostropheCMS: Archive duplicate continuation lets contributors overwrite published content


- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 20 Oct 2026
- **Updated:** 20 Oct 2026
- **Also known as:** GHSA-jf5h-36mg-rp6x

## What is CVE-2026-112956?

CVE-2026-112956 is a medium-severity vulnerability in @apostrophecms apostrophe, published on 20 Oct 2026. 

### Official description

ApostropheCMS is an open-source Node.js content management system. Prior to 3.7.1 of the import-export module, duplicate-import continuation accepts client-controlled replacement choices without binding them to a user-owned server-side analysis or authorizing the canonical target. On an import-enabled localized type, a contributor with draft editing authority can cross the publication boundary by selecting a published document for replacement, although the current assessment is based on remediation review rather than a repeated end-to-end reproduction. This issue is fixed in version 3.7.1.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-112956?

2 open source packages ship an affected version, including @apostrophecms/import-export.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@apostrophecms/import-export` | npm | All versions | 3.7.1 |
| `@apostrophecms/import-export` | npm | All versions | 3.7.1 |

## How do I fix CVE-2026-112956?

Upgrade @apostrophecms/import-export to 3.7.1 or later.

## Is CVE-2026-112956 being exploited?

There is no known exploitation of CVE-2026-112956 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-112956 and fix it if it is affected.

What it is: CVE-2026-112956 is a medium-severity vulnerability in @apostrophecms apostrophe, published on 20 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-112956 in the wild and no public exploit code.

Affected packages and fixed versions:
- @apostrophecms/import-export (npm): affected all versions; fixed in 3.7.1
- @apostrophecms/import-export (npm): affected all versions; fixed in 3.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-112956/ (Markdown: https://insights.sbomify.com/CVE-2026-112956/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-112956
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-112956
- OSV: https://osv.dev/vulnerability/CVE-2026-112956

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-112956/
Summaries are generated and may contain mistakes; the official description above is the record.
