# CVE-2026-112957: ApostropheCMS: GET /api/v1/@apostrophecms/page/:id bypasses viewRole restriction and exposes viewPermission-gated fields to lower-privileged users


- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 20 Oct 2026
- **Updated:** 21 Oct 2026
- **Also known as:** GHSA-vh56-5m88-39rq

## What is CVE-2026-112957?

CVE-2026-112957 is a medium-severity vulnerability in apostrophecms apostrophe, published on 20 Oct 2026. 

### Official description

ApostropheCMS is an open-source Node.js content management system. Prior to 4.34.0, the getOne REST endpoint for pages does not apply viewRole type-level restrictions or viewPermission field-level redaction. An editor-level user who knows a document _id can read the full content of admin-only pages and their privileged fields, while the getAll endpoint correctly enforces both restrictions. This issue is fixed in version 4.34.0.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-112957?

2 open source packages ship an affected version, including apostrophe.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apostrophe` | npm | All versions | 4.34.0 |
| `apostrophe` | npm | All versions | 4.34.0 |

## How do I fix CVE-2026-112957?

Upgrade apostrophe to 4.34.0 or later.

## Is CVE-2026-112957 being exploited?

There is no known exploitation of CVE-2026-112957 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-112957 and fix it if it is affected.

What it is: CVE-2026-112957 is a medium-severity vulnerability in apostrophecms apostrophe, published on 20 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-112957 in the wild and no public exploit code.

Affected packages and fixed versions:
- apostrophe (npm): affected all versions; fixed in 4.34.0
- apostrophe (npm): affected all versions; fixed in 4.34.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-112957/ (Markdown: https://insights.sbomify.com/CVE-2026-112957/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-112957
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-112957
- OSV: https://osv.dev/vulnerability/CVE-2026-112957

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-112957/
Summaries are generated and may contain mistakes; the official description above is the record.
