{"answers":{"affected":"1 open source package ship an affected version, including nginx-gateway-fabric. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-11311 in the wild and no public exploit code.","fix":"Upgrade nginx-gateway-fabric to 2.6.4 or later.","what":"CVE-2026-11311 is a high-severity code injection vulnerability in F5 NGINX Gateway Fabric, published on 17 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-11311 and fix it if it is affected.\n\nWhat it is: CVE-2026-11311 is a high-severity code injection vulnerability in F5 NGINX Gateway Fabric, published on 17 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-11311 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nginx-gateway-fabric (Bitnami): affected from 2.5.0; fixed in 2.6.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-11311/ (Markdown: https://insights.sbomify.com/CVE-2026-11311/index.md)","id":"CVE-2026-11311","markdown":"https://insights.sbomify.com/CVE-2026-11311/index.md","name":"CVE-2026-11311","record":{"aliases":["BIT-nginx-gateway-fabric-2026-11311","GHSA-9566-3h6w-56pp"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":true,"product_category":"NGINX Gateway Fabric","requires_auth":"low_privilege","summary":"Authenticated attackers can inject arbitrary NGINX directives via unsanitized CRD fields, potentially leading to code execution or privilege escalation.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"f5","cpe":[{"product":"nginx_gateway_fabric","vendor":"f5"}],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"},{"id":"CWE-76","name":"Improper Neutralization of Equivalent Special Elements"}],"description":"When NGINX Plus is configured as the data plane for NGINX Gateway Fabric, an injection vulnerability exists in the NGINX configuration generator component of NGINX Gateway Fabric. User-supplied string values from the NginxProxy Custom Resource Definition serverTokens field and the AuthenticationFilter Custom Resource Definition extraAuthArgs field are rendered directly into NGINX configuration templates without sanitization or escaping. An authenticated attacker with permission to create or modify these Custom Resource Definitions may craft values that inject arbitrary NGINX configuration directives. This is a control plane issue; there is no data plane exposure from the vulnerability trigger itself. \n\nNote: Software versions which have reached End of Technical Support (EoTS) are not evaluated.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"NGINX Gateway Fabric vulnerability","id":"CVE-2026-11311","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":1,"n_references":1,"next":{"headline":"bytedance InfiniStore KV Map infinistore.h purge_kv_map algorithmic complexity","id":"CVE-2026-11312"},"packages":[{"ecosystem":"Bitnami","fixed":["2.6.4"],"introduced":["2.5.0"],"last_affected":[],"package":"nginx-gateway-fabric","purl":"pkg:bitnami/nginx-gateway-fabric","source":"BIT-nginx-gateway-fabric-2026-11311"}],"prev":{"headline":"X.509 trust-chain bypass in wolfSSL_X509_verify_cert() via untrusted intermediate anchoring","id":"CVE-2026-11310"},"products":["NGINX Gateway Fabric"],"published":"2026-06-17","related":[{"cvss_score":9.2,"headline":"NGINX Map directive and Regex matching vulnerability","id":"CVE-2026-42533","kev_date_added":null,"published":"2026-07-15"},{"cvss_score":9.2,"headline":"NGINX Open-Source ngx_http_v3_module vulnerability","id":"CVE-2026-42530","kev_date_added":null,"published":"2026-06-17"},{"cvss_score":8.8,"headline":"NGINX ngx_http_slice_module vulnerability","id":"CVE-2026-60005","kev_date_added":null,"published":"2026-07-15"},{"cvss_score":8.6,"headline":"NGINX Gateway Fabric vulnerability","id":"CVE-2026-50107","kev_date_added":null,"published":"2026-06-17"},{"cvss_score":8.3,"headline":"NGINX ngx_http_ssi_module vulnerability","id":"CVE-2026-56434","kev_date_added":null,"published":"2026-07-15"},{"cvss_score":8.2,"headline":"NGINX vulnerability","id":"CVE-2026-1642","kev_date_added":null,"published":"2026-02-04"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-06-17","vendors":["F5"]},"summary":"Authenticated attackers can inject arbitrary NGINX directives via unsanitized CRD fields, potentially leading to code execution or privilege escalation.","url":"https://insights.sbomify.com/CVE-2026-11311/"}