# CVE-2026-11311: NGINX Gateway Fabric vulnerability

> Authenticated attackers can inject arbitrary NGINX directives via unsanitized CRD fields, potentially leading to code execution or privilege escalation.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jun 2026
- **Updated:** 17 Jun 2026
- **Also known as:** BIT-nginx-gateway-fabric-2026-11311, GHSA-9566-3h6w-56pp

## What is CVE-2026-11311?

CVE-2026-11311 is a high-severity code injection vulnerability in F5 NGINX Gateway Fabric, published on 17 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

When NGINX Plus is configured as the data plane for NGINX Gateway Fabric, an injection vulnerability exists in the NGINX configuration generator component of NGINX Gateway Fabric. User-supplied string values from the NginxProxy Custom Resource Definition serverTokens field and the AuthenticationFilter Custom Resource Definition extraAuthArgs field are rendered directly into NGINX configuration templates without sanitization or escaping. An authenticated attacker with permission to create or modify these Custom Resource Definitions may craft values that inject arbitrary NGINX configuration directives. This is a control plane issue; there is no data plane exposure from the vulnerability trigger itself. 

Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component), CWE-76 (Improper Neutralization of Equivalent Special Elements)

## Which versions are affected by CVE-2026-11311?

1 open source package ship an affected version, including nginx-gateway-fabric. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nginx-gateway-fabric` | Bitnami | From 2.5.0 | 2.6.4 |

Products: F5 Nginx Gateway Fabric.

## How do I fix CVE-2026-11311?

Upgrade nginx-gateway-fabric to 2.6.4 or later.

## Is CVE-2026-11311 being exploited?

There is no known exploitation of CVE-2026-11311 in the wild and no public exploit code.

## Other vulnerabilities in F5 NGINX Gateway Fabric

- [CVE-2026-42533](https://insights.sbomify.com/CVE-2026-42533/): NGINX Map directive and Regex matching vulnerability (critical 9.2)
- [CVE-2026-42530](https://insights.sbomify.com/CVE-2026-42530/): NGINX Open-Source ngx_http_v3_module vulnerability (critical 9.2)
- [CVE-2026-60005](https://insights.sbomify.com/CVE-2026-60005/): NGINX ngx_http_slice_module vulnerability (high 8.8)
- [CVE-2026-50107](https://insights.sbomify.com/CVE-2026-50107/): NGINX Gateway Fabric vulnerability (high 8.6)
- [CVE-2026-56434](https://insights.sbomify.com/CVE-2026-56434/): NGINX ngx_http_ssi_module vulnerability (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-11311 and fix it if it is affected.

What it is: CVE-2026-11311 is a high-severity code injection vulnerability in F5 NGINX Gateway Fabric, published on 17 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-11311 in the wild and no public exploit code.

Affected packages and fixed versions:
- nginx-gateway-fabric (Bitnami): affected from 2.5.0; fixed in 2.6.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-11311/ (Markdown: https://insights.sbomify.com/CVE-2026-11311/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-11311
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-11311
- OSV: https://osv.dev/vulnerability/CVE-2026-11311

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-11311/
Summaries are generated and may contain mistakes; the official description above is the record.
