# CVE-2026-113440: HTTP/1.1 and HTTP/2 redirects resend basic_auth and cookie to a different scheme or port in hackney


- **Severity:** Medium 6.0 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 26 Oct 2026
- **Updated:** 26 Oct 2026
- **Also known as:** EEF-CVE-2026-113440, GHSA-m347-hm9w-wwv9

## What is CVE-2026-113440?

CVE-2026-113440 is a medium-severity vulnerability in benoitc hackney, published on 26 Oct 2026. 

### Official description

Insufficiently Protected Credentials vulnerability in hackney in benoitc hackney allows a redirecting server to obtain the basic_auth and cookie credentials of a request via a same-host redirect to another scheme or port. With follow_redirect enabled, hackney:follow_redirect/10 in src/hackney.erl reissues the request to the Location target after hackney:maybe_strip_auth_on_redirect/3, which compared only the hostname of the current and the redirect URL. A redirect from https to http on the same host resent the Authorization and Cookie headers in cleartext, where an on-path attacker can read them, and a redirect to another port on the same host handed them to a different service. location_trusted forwards credentials to any target by design and is unchanged.

This issue affects hackney: from 2.0.0 before 4.9.0.

Weakness: CWE-522 (Insufficiently Protected Credentials)

## Which versions are affected by CVE-2026-113440?

1 open source package ship an affected version, including hackney.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `hackney` | Hex | From 2.0.0 | 4.9.0 |

## How do I fix CVE-2026-113440?

Upgrade hackney to 4.9.0 or later.

## Is CVE-2026-113440 being exploited?

There is no known exploitation of CVE-2026-113440 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-113440 and fix it if it is affected.

What it is: CVE-2026-113440 is a medium-severity vulnerability in benoitc hackney, published on 26 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-113440 in the wild and no public exploit code.

Affected packages and fixed versions:
- hackney (Hex): affected from 2.0.0; fixed in 4.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-113440/ (Markdown: https://insights.sbomify.com/CVE-2026-113440/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-113440
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-113440
- OSV: https://osv.dev/vulnerability/CVE-2026-113440

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-113440/
Summaries are generated and may contain mistakes; the official description above is the record.
