CVE-2026-113649 ApostropheCMS: Import API bypasses publication roles for protected content

Medium 6.5 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2026-113649?

CVE-2026-113649 is a medium-severity vulnerability in @apostrophecms apostrophe, published on 20 Oct 2026.

Official description

ApostropheCMS is an open-source Node.js content management system. Prior to 3.7.1 of the import-export module and 4.34.0 of core ApostropheCMS, an editor who can import an enabled content type but lacks its stronger publication role can cause import write helpers to create, replace, or remove published variants without the normal publish permission and lifecycle checks. This issue is fixed in import-export 3.7.1 and ApostropheCMS 4.34.0.

Weakness: CWE-862

Which versions are affected by CVE-2026-113649?

4 open source packages ship an affected version, including @apostrophecms/import-export and apostrophe.

PackageAffectedFixed in
@apostrophecms/import-export npmAll versions3.7.1
@apostrophecms/import-export npmAll versions3.7.1
apostrophe npmAll versions4.34.0
apostrophe npmAll versions4.34.0

How do I fix CVE-2026-113649?

Upgrade @apostrophecms/import-export to 3.7.1 or later.

Is CVE-2026-113649 being exploited?

There is no known exploitation of CVE-2026-113649 in the wild and no public exploit code.

Sources

Also known as GHSA-5m22-7pfq-vp65.

Is CVE-2026-113649 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free