# CVE-2026-113649: ApostropheCMS: Import API bypasses publication roles for protected content


- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 20 Oct 2026
- **Updated:** 23 Oct 2026
- **Also known as:** GHSA-5m22-7pfq-vp65

## What is CVE-2026-113649?

CVE-2026-113649 is a medium-severity vulnerability in @apostrophecms apostrophe, published on 20 Oct 2026. 

### Official description

ApostropheCMS is an open-source Node.js content management system. Prior to 3.7.1 of the import-export module and 4.34.0 of core ApostropheCMS, an editor who can import an enabled content type but lacks its stronger publication role can cause import write helpers to create, replace, or remove published variants without the normal publish permission and lifecycle checks. This issue is fixed in import-export 3.7.1 and ApostropheCMS 4.34.0.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-113649?

4 open source packages ship an affected version, including @apostrophecms/import-export and apostrophe.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@apostrophecms/import-export` | npm | All versions | 3.7.1 |
| `@apostrophecms/import-export` | npm | All versions | 3.7.1 |
| `apostrophe` | npm | All versions | 4.34.0 |
| `apostrophe` | npm | All versions | 4.34.0 |

## How do I fix CVE-2026-113649?

Upgrade @apostrophecms/import-export to 3.7.1 or later.

## Is CVE-2026-113649 being exploited?

There is no known exploitation of CVE-2026-113649 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-113649 and fix it if it is affected.

What it is: CVE-2026-113649 is a medium-severity vulnerability in @apostrophecms apostrophe, published on 20 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-113649 in the wild and no public exploit code.

Affected packages and fixed versions:
- @apostrophecms/import-export (npm): affected all versions; fixed in 3.7.1
- @apostrophecms/import-export (npm): affected all versions; fixed in 3.7.1
- apostrophe (npm): affected all versions; fixed in 4.34.0
- apostrophe (npm): affected all versions; fixed in 4.34.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-113649/ (Markdown: https://insights.sbomify.com/CVE-2026-113649/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-113649
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-113649
- OSV: https://osv.dev/vulnerability/CVE-2026-113649

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-113649/
Summaries are generated and may contain mistakes; the official description above is the record.
