# CVE-2026-113652: ApostropheCMS uploadfs Azure backend leaks account-level SAS token into every public attachment URL (sas: true)


- **Severity:** Medium 5.6 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 20 Oct 2026
- **Updated:** 21 Oct 2026
- **Also known as:** GHSA-hhph-8536-gfq5

## What is CVE-2026-113652?

CVE-2026-113652 is a medium-severity vulnerability in apostrophecms apostrophe, published on 20 Oct 2026. 

### Official description

ApostropheCMS is an open-source Node.js content management system. From 1.25.0 until 1.28.0, uploadfs Azure backend leaks account-level SAS token into every public attachment URL. When uploadfs is configured with the Azure backend and sas: true, createContainer() builds the BlobServiceClient from a URL that embeds the full SAS query string, and Azure SDK v12 derived clients inherit that query string. This issue is fixed in version 1.28.0.

Weakness: CWE-522 (Insufficiently Protected Credentials), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-113652?

2 open source packages ship an affected version, including uploadfs.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `uploadfs` | npm | From 1.25.0 | 1.28.0 |
| `uploadfs` | npm | From 1.25.0 | 1.28.0 |

## How do I fix CVE-2026-113652?

Upgrade uploadfs to 1.28.0 or later.

## Is CVE-2026-113652 being exploited?

There is no known exploitation of CVE-2026-113652 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-113652 and fix it if it is affected.

What it is: CVE-2026-113652 is a medium-severity vulnerability in apostrophecms apostrophe, published on 20 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-113652 in the wild and no public exploit code.

Affected packages and fixed versions:
- uploadfs (npm): affected from 1.25.0; fixed in 1.28.0
- uploadfs (npm): affected from 1.25.0; fixed in 1.28.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-113652/ (Markdown: https://insights.sbomify.com/CVE-2026-113652/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-113652
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-113652
- OSV: https://osv.dev/vulnerability/CVE-2026-113652

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-113652/
Summaries are generated and may contain mistakes; the official description above is the record.
