# CVE-2026-113654: ApostropheCMS sanitize-html: nonTextTags discard region ends early on an implied close, letting <noscript> content render


- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 20 Oct 2026
- **Updated:** 28 Oct 2026
- **Also known as:** ECHO-2746-5d30-75b8, GHSA-x3q4-9hxx-gx8m

## What is CVE-2026-113654?

CVE-2026-113654 is a medium-severity vulnerability in apostrophecms apostrophe, published on 20 Oct 2026. 

### Official description

ApostropheCMS is an open-source Node.js content management system, and sanitize-html provides a simple HTML sanitizer with a clear API. Prior to sanitize-html 2.18.0, a non-default nonTextTags configuration that includes noscript can end its discard region early when htmlparser2 emits an implied ancestor close inside noscript. Because scripting-enabled browsers treat noscript content as raw text while the parser does not model that mode, content intended to remain inert can survive sanitization and render; the issue does not generalize to every default nonTextTags element. This issue is fixed in sanitize-html 2.18.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-113654?

2 open source packages ship an affected version, including sanitize-html.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sanitize-html` | npm | All versions | 2.18.0 |
| `sanitize-html` | npm | All versions | 2.18.0 |

## How do I fix CVE-2026-113654?

Upgrade sanitize-html to 2.18.0 or later.

## Is CVE-2026-113654 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-113654 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-113654 and fix it if it is affected.

What it is: CVE-2026-113654 is a medium-severity vulnerability in apostrophecms apostrophe, published on 20 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-113654 exists.

Affected packages and fixed versions:
- sanitize-html (npm): affected all versions; fixed in 2.18.0
- sanitize-html (npm): affected all versions; fixed in 2.18.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-113654/ (Markdown: https://insights.sbomify.com/CVE-2026-113654/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-113654
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-113654
- OSV: https://osv.dev/vulnerability/CVE-2026-113654

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-113654/
Summaries are generated and may contain mistakes; the official description above is the record.
